cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
779 Views
Registered: ‎03-22-2016

Petalinux SSH login always fails the first time

Jump to solution

When I ssh into a Zynq device running Petalinux, the first password attempt always fails, and subsequent attempts always succeed. This occurs with every ssh login or scp transfer. This occurs with multiple devices, including ZynqMP and RFSoC devices.

I'm not sure which specific version of Petalinux introduced this issue and have not done a lot to debug the issue, yet.

I just wanted to see if this is widespread and whether it is a known issue before I continue trying to debug it. Thanks!

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Voyager
Voyager
635 Views
Registered: ‎10-21-2015

Hi

Your problem is due to the default option(-w) of dropbear which disables root logins

The solution is https://forums.xilinx.com/t5/Embedded-Linux/dropbear-root-login-petalinux-2019-1/td-p/979852

View solution in original post

5 Replies
Highlighted
Moderator
Moderator
747 Views
Registered: ‎04-24-2017

Hi @jeffsimpson ,

You to enable debug-tweaks in build to connect via ssh for the first time.

$ petalinux-config ---> Yocto Settings ---> [*] Enable Debug Tweaks

Note: Enabling Debug tweaks also enables autologin.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
Highlighted
Scholar
Scholar
734 Views
Registered: ‎05-28-2013

Could the first prompt actually be for a passphrase (on a local ssh key) rather than for a password? You can try using "ssh -v" to enable verbose mode.

0 Kudos
Highlighted
Voyager
Voyager
636 Views
Registered: ‎10-21-2015

Hi

Your problem is due to the default option(-w) of dropbear which disables root logins

The solution is https://forums.xilinx.com/t5/Embedded-Linux/dropbear-root-login-petalinux-2019-1/td-p/979852

View solution in original post

Highlighted
Moderator
Moderator
560 Views
Registered: ‎04-24-2017

Hi All,

As I mentioned earlier debug-tweaks is the right way to do it from PetaLinux or Yocto (alternatively allow-empty-password option) See below commit for Purdie.

https://github.com/openembedded/openembedded-core/commit/d3e69fa2fef83015658aa5fa1442bab5a8c3edaa#diff-874bf0754858c24b4a7511e08ef887b9

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
Highlighted
Explorer
Explorer
547 Views
Registered: ‎03-22-2016

> As I mentioned earlier debug-tweaks is the right way to do it from PetaLinux or Yocto

I thought you said that enabling Debug Tweaks would also enable auto-login? Is there a way to fix the ssh issue without enabling auto-login?