UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer carljwhite3
Observer
649 Views
Registered: ‎07-28-2019

Petalinx 2019.1 Failed to generate meta-plnx-generated layer

Hi,

 

   I'm trying to figure out why the petalinux-config step fails to generate meta-plnx-generated layer?

Is there someway to debug why the failure occurs by looking at a log file?

Output:

johnnie@johnnie-VirtualBox:/media/sf_PetaLinux/arty_petalinux$ petalinux-config --get-hw-description ../PetaLinux.sdk --oldconfig
WARNING: --oldconfig will be deprecated in the feature releases,Please use --silentconfig.
INFO: Getting hardware description...
INFO: Rename system_wrapper.hdf to system.hdf
[INFO] generating Kconfig for project
INFO: Updating the flash partition size to 0x200000 bytes, based on the bitstream in the HDF
[INFO] silentconfig project
[INFO] sourcing bitbake
[INFO] generating plnxtool conf
[INFO] generating meta-plnx-generated layer
ERROR: Failed to generate meta-plnx-generated layer
ERROR: Failed to config project.
ERROR: Get hw description Failed!.

Thanks,

Johnnie White

0 Kudos
2 Replies
Observer carljwhite3
Observer
601 Views
Registered: ‎07-28-2019

Re: Petalinx 2019.1 Failed to generate meta-plnx-generated layer

Think I resolved the issue.  I was using a VirtualBox folder share and either it didn't like the fact that it was on a NTFS partition, file ownership or file permissions.

Highlighted
Visitor zinnc
Visitor
320 Views
Registered: ‎08-06-2014

Re: Petalinx 2019.1 Failed to generate meta-plnx-generated layer

I met the same issue. Looks like the reason is petalinux-config can only use python2.7, but my default link to python is python3.7 from anaconda3.

My solution is creating a virtual env by conda, and use petalinux-config in it. 

conda create --name petalinux python=2.7
conda activate petalinux