UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant garazigara
Participant
4,246 Views
Registered: ‎11-13-2008

Problem with ELDK 4.2 installation

Jump to solution

Hello,

 

We're working with ELDK 4.1, but today we've tried to install 4.2 version in other PC and the following error appears:

 

 Preparing...                ########################################### [100%]
   1:xenomai-ppc_4xx        ########################################### [100%]
Configuring Xenomai kernel...
  CLEAN   /opt/ELDK/4.2/ppc_4xx/usr/src/linux-2.6.24-xenomai
  CLEAN   .tmp_versions
  CLEAN   .tmp_gas_check
  CLEAN   scripts/kconfig
  CLEAN   scripts/mod
  CLEAN   include/config
  CLEAN   .config include/asm include/linux/autoconf.h include/linux/version.h include/linux/utsrelease.h
/opt/ELDK/4.2/ppc_4xx/usr/local/xenomai/kbuild/scripts/prepare-kernel.sh: line 405: patch: command not found
prepare-kernel.sh: Unable to patch kernel 2.6.24.2 with adeos-ipipe-2.6.24-powerpc-DENX-2.1-00.patch.
error: %post(xenomai-ppc_4xx-2.4.2-1.ppc) scriptlet failed, exit status 2
bmartinez@andLinux:/tmp/cdrom$

 

Any idea?

 

Thanks in advance,

 

Borja and Garazi

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
5,043 Views
Registered: ‎09-10-2008

Re: Problem with ELDK 4.2 installation

Jump to solution

I have installed the ELDK 4.2 previously without issue.

 

When I look at the error below, are you sure that the patch utility is available on this host where you're installing as that's the error?

 

You may want to get on an ELDK mailing list for this also?

 

Sorry I'm not more help, but I have only installed a couple times without any issue.  

 

CLEAN   .config include/asm include/linux/autoconf.h include/linux/version.h include/linux/utsrelease.h
/opt/ELDK/4.2/ppc_4xx/usr/local/xenomai/kbuild/scripts/prepare-kernel.sh: line 405: patch: command not found
prepare-kernel.sh: Unable to patch kernel 2.6.24.2 with adeos-ipipe-2.6.24-powerpc-DENX-2.1-00.patch.
error: %post(xenomai-ppc_4xx-2.4.2-1.ppc) scriptlet failed, exit status 2
bmartinez@andLinux:/tmp/cdrom$

View solution in original post

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
5,044 Views
Registered: ‎09-10-2008

Re: Problem with ELDK 4.2 installation

Jump to solution

I have installed the ELDK 4.2 previously without issue.

 

When I look at the error below, are you sure that the patch utility is available on this host where you're installing as that's the error?

 

You may want to get on an ELDK mailing list for this also?

 

Sorry I'm not more help, but I have only installed a couple times without any issue.  

 

CLEAN   .config include/asm include/linux/autoconf.h include/linux/version.h include/linux/utsrelease.h
/opt/ELDK/4.2/ppc_4xx/usr/local/xenomai/kbuild/scripts/prepare-kernel.sh: line 405: patch: command not found
prepare-kernel.sh: Unable to patch kernel 2.6.24.2 with adeos-ipipe-2.6.24-powerpc-DENX-2.1-00.patch.
error: %post(xenomai-ppc_4xx-2.4.2-1.ppc) scriptlet failed, exit status 2
bmartinez@andLinux:/tmp/cdrom$

View solution in original post

0 Kudos
Participant garazigara
Participant
4,163 Views
Registered: ‎11-13-2008

Re: Problem with ELDK 4.2 installation

Jump to solution
Thanks, we installed the xenomai patch and it worked fine.
0 Kudos