UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor noel.aye
Visitor
568 Views
Registered: ‎02-26-2018

RPU powerdown

Jump to solution

For v2017.2, we are able to powerdown rpu 1 using the following command:

echo request_wakeup 8 1 0 1 > /sys/kernel/debug/zynqmp_pm/power
echo force_powerdown 6 > /sys/kernel/debug/zynqmp_pm/power

But, for v2018.2, the above twos are no longer working.

Is there any alternative to these commands?

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
460 Views
Registered: ‎04-15-2011

回复: RPU powerdown

Jump to solution

I haven't tried to power down RPU yet. But the pm path is different in 2018.2. You can refer to turn off PL in below link.

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841757/ZU+Example+-+Typical+Power+States

 8.1 Turn off PL

(v2017.1-4) Run below command from Linux terminal on board to power off PL (force power down unused PU).

root@plnx_aarch64:~# echo request_wakeup 8 1 0 1 > /sys/kernel/debug/zynqmp_pm/power
root@plnx_aarch64:~# echo force_powerdown 8 >  /sys/kernel/debug/zynqmp_pm/power
root@plnx_aarch64:~# time echo release_node 69 > /sys/kernel/debug/zynqmp_pm/power

 

(v2018.1-x) Run below command from Linux terminal on board to power off PL (force power down unused PU).

root@plnx_aarch64:~# echo pm_request_wakeup 8 1 0 1 > /sys/kernel/debug/zynqmp-firmware/pm
root@plnx_aarch64:~# echo pm_force_powerdown 8 >  /sys/kernel/debug/zynqmp-firmware/pm
root@plnx_aarch64:~# time echo pm_release_node 69 > /sys/kernel/debug/zynqmp-firmware/pm
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
461 Views
Registered: ‎04-15-2011

回复: RPU powerdown

Jump to solution

I haven't tried to power down RPU yet. But the pm path is different in 2018.2. You can refer to turn off PL in below link.

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841757/ZU+Example+-+Typical+Power+States

 8.1 Turn off PL

(v2017.1-4) Run below command from Linux terminal on board to power off PL (force power down unused PU).

root@plnx_aarch64:~# echo request_wakeup 8 1 0 1 > /sys/kernel/debug/zynqmp_pm/power
root@plnx_aarch64:~# echo force_powerdown 8 >  /sys/kernel/debug/zynqmp_pm/power
root@plnx_aarch64:~# time echo release_node 69 > /sys/kernel/debug/zynqmp_pm/power

 

(v2018.1-x) Run below command from Linux terminal on board to power off PL (force power down unused PU).

root@plnx_aarch64:~# echo pm_request_wakeup 8 1 0 1 > /sys/kernel/debug/zynqmp-firmware/pm
root@plnx_aarch64:~# echo pm_force_powerdown 8 >  /sys/kernel/debug/zynqmp-firmware/pm
root@plnx_aarch64:~# time echo pm_release_node 69 > /sys/kernel/debug/zynqmp-firmware/pm
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor noel.aye
Visitor
425 Views
Registered: ‎02-26-2018

回复: RPU powerdown

Jump to solution

Thanks, we have tried the solution and found perfectly working.

One thing to add is that we need to build the kernel with

CONFIG_ZYNQMP_FIRMWARE_DEBUG=y

to see the node "/sys/kernel/debug/zynqmp-firmware/pm".

0 Kudos