UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor sathaps2
Visitor
2,222 Views
Registered: ‎05-06-2013

U-Boot stuck at "loading ramdisk"?

Hi All,

     while U-Boot is loading ramdisk from qspi to RAM, My U-Boot got stuck. These are the messages from the serial port. Anybody faced this or any hint?  [I have not configured the watchdog in my XPS, could this have anything to do with this?]

 

 

///////////////////////////////////////

///////////////////////////////////////

///////////////////////////////////////

U-Boot 2013.01 (Apr 18 2013 - 09:59:59)

I2C: ready
DRAM: 1 GiB
WARNING: Caches not enabled
MMC: zynq_sdhci: 0
SF: Detected N25Q256 with page size 64 KiB, total 32 MiB
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Net: Gem.e000b000
Hit any key to stop autoboot: 0
Copying Linux from QSPI flash to RAM...
SF: Detected N25Q256 with page size 64 KiB, total 32 MiB
Copying ramdisk...
## Booting kernel from Legacy Image at 03000000 ...
Image Name: Linux-3.8.0-xilinx
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2883408 Bytes = 2.7 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 02000000 ...
Image Name:
Image Type: ARM Linux RAMDisk Image (gzip compressed)
Data Size: 4506945 Bytes = 4.3 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
## Flattened Device Tree blob at 02a00000
Booting using the fdt blob at 0x02a00000
Loading Kernel Image ... OK
OK
Loading Ramdisk to 1fbb3000, end 1ffff541 ...

0 Kudos