cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
1,253 Views
Registered: ‎06-09-2018

Unable to install PetaLinux

Jump to solution

I received the message below trying to install PetaLinux. I checked that I do see that I have diffstat installed in a local directory. Any ideas?

 

 

PetaLinux Extensible SDK installer version 2018.1
=================================================
ERROR: the SDK requires the following missing utilities, please install them: diffstat
*********************************************
ERROR: Failed to install Yocto SDK for aarch64.
*********************************************

Please refer to the PetaLinux Tools Installation Guide.

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
1,343 Views
Registered: ‎06-09-2018

I found the installation script for installing the Yocto SDK. In the script it creates a new environment with minimal environment variables and it only sets PATH with the default /usr/bin and other paths that Linux would typically find executable's. The script would not find my local diffstat since the script did not use my modified PATH. Luckily the script had a variable $ENVCLEANED which would use the current shell environment instead of creating a new one with minimal variables. Once I set $ENVCLEANED and also needed to set $LC_ALL, I was able to install PetaLinux.

View solution in original post

0 Kudos
5 Replies
Highlighted
Adventurer
Adventurer
1,238 Views
Registered: ‎04-24-2012

Hello garrett.c.chan@aero.org ... couple of questions,

What Linux distro are you using?, could you please check that you have all the packages installed from this document: https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_1/ug1144-petalinux-tools-reference-guide.pdf , page 9.

 

I'm running petalinux 2018.1 fine in RHEL 7.4

Also, where you diffstat binary is located?

 

$ which diffstat
/usr/bin/diffstat

/* Don't forget to give kudos and/or accept as a solution */
0 Kudos
Highlighted
1,234 Views
Registered: ‎06-09-2018
It is CentOS 7.5. The binary is located in my home directory.
0 Kudos
Highlighted
Adventurer
Adventurer
1,233 Views
Registered: ‎04-24-2012

But is in your path too?, if you type in the terminal:

$ diffstat  -h options should appear in the terminal, otherwise an error will shown and you must add it to the path:

$ export PATH=$PATH:<directory_where_diffstat_is_located>

 

Also, is preferable that you use YUM command to install all the packages you need, unless you have no sudo permissions.

/* Don't forget to give kudos and/or accept as a solution */
0 Kudos
Highlighted
1,199 Views
Registered: ‎06-09-2018
Yes it does recognize the command and it is in $PATH.
0 Kudos
Highlighted
1,344 Views
Registered: ‎06-09-2018

I found the installation script for installing the Yocto SDK. In the script it creates a new environment with minimal environment variables and it only sets PATH with the default /usr/bin and other paths that Linux would typically find executable's. The script would not find my local diffstat since the script did not use my modified PATH. Luckily the script had a variable $ENVCLEANED which would use the current shell environment instead of creating a new one with minimal variables. Once I set $ENVCLEANED and also needed to set $LC_ALL, I was able to install PetaLinux.

View solution in original post

0 Kudos