UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer kevin.jesse
Observer
6,488 Views
Registered: ‎02-16-2015

WARNING: Will not program bitstream on the target

Jump to solution

Hi Guys,

 

Even after running

 

[root@localhost test]# petalinux-package --prebuilt --fpga ./subsystems/linux/hw-description/base_zynq_design_wrapper.bit
INFO: Pre-built directory is updated.

 

I still can't get the bitstream on the board and it hangs at Petalinux boot hangs on: 'Waiting for PHY auto negotiation to complete..'

 

Is the bitstream getting put on the board? Is the processor just stopped. I tried starting it as suggested here,

 

http://forums.xilinx.com/t5/Embedded-Linux/Petalinux-boot-hangs-on-Waiting-for-PHY-auto-negotiation-to/m-p/475328#M9489

 

but with no such luck. My console output is below

 

Thanks,

Kevin

0 Kudos
1 Solution

Accepted Solutions
Observer kevin.jesse
Observer
11,047 Views
Registered: ‎02-16-2015

Re: WARNING: Will not program bitstream on the target

Jump to solution

My solution was to use the BSP and import my project rather than using an empty zynq project.

 

Kevin

0 Kudos
5 Replies
Xilinx Employee
Xilinx Employee
6,481 Views
Registered: ‎10-24-2013

Re: WARNING: Will not program bitstream on the target

Jump to solution
Hi,
Moving to Embedded linux board.
Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Observer kevin.jesse
Observer
6,406 Views
Registered: ‎02-16-2015

Re: WARNING: Will not program bitstream on the target

Jump to solution

Any followup on this? I'm sure someone has been able to get a vivado project to compile with petalinux AND program the bitstream to the board. What could I be doing wrong??

 

Kevin

0 Kudos
Scholar rfs613
Scholar
6,363 Views
Registered: ‎05-28-2013

Re: WARNING: Will not program bitstream on the target

Jump to solution
Hi Kevin,

There can be many possible causes, but the most common one is having devices listed in the device tree (DTS) which are not actually present. The best way to debug is to enable earlydebug, or alternatively, you can read the kernel log manually via JTAG tools. The steps for the latter are explained here: http://www.wiki.xilinx.com/Debugging+PowerPC+Kernel+Boot+Problems (even though it is for PowerPC, the same process applies on Zynq. You are basically looking for address of the log_buf symbol, and dumping out the memory at that location).

Before resorting to that, I would suggest you try booting with a "minimal" DTS for your board. If you are based of a reference design, try the DTS that came with it, and comment out any of the non-essential peripherals. In particular you might leave out the ethernet interfaces initially. Once you get it booting (or some form of output after "Decompressing linux..." then you can start adding back in devices).

-R
0 Kudos
Observer kevin.jesse
Observer
11,048 Views
Registered: ‎02-16-2015

Re: WARNING: Will not program bitstream on the target

Jump to solution

My solution was to use the BSP and import my project rather than using an empty zynq project.

 

Kevin

0 Kudos
Highlighted
Newbie ishy
Newbie
2,169 Views
Registered: ‎07-21-2016

Re: WARNING: Will not program bitstream on the target

Jump to solution

@kevin.jesse wrote:

My solution was to use the BSP and import my project rather than using an empty zynq project.

 

Kevin


Just rename the bit-stream filename to download.bit, it will work well;

e.g. : if you generate a bitstream file design_wrapper.bit in Vivado, you should modify its name (download.bit) under the directory "pre-built/Linux/implementation"