UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer ndimou
Observer
594 Views
Registered: ‎05-13-2015

Zynq Ultrascale+ GEM: Configuring PHY to run at 100Mbps

Jump to solution

Hi, we have a custom board with a Zynq Ultrascale+. Its GEM3 interface is connected to a Marvell Linkstreet PHY.  We would need to configure the PHY to run at 100Mbps or less (because of PCB limitations). We were able to achieve this using ad-hoc TCL scripts (issuing SMI commands to the PHY). Then we tried various device tree configurations, but the interface keeps running at 1000Mbps:

 

- Setting the PHY as fixed-link does not seem to solve the issue, probably because it does not configure the PHY.

- Setting speed or max-speed oin the GEM blob does not help

- We also tried to insert a blob for the PHY, with no success so far

 

How can we configure the PHY to be configured at 100Mbps in Linux?

 

Thanks

 

 

0 Kudos
1 Solution

Accepted Solutions
Observer ndimou
Observer
711 Views
Registered: ‎05-13-2015

Re: Zynq Ultrascale+ GEM: Configuring PHY to run at 100Mbps

Jump to solution

Hi again. thanks for answering.

We managed to get it working by adding a blob for the PHY in the device tree and adding an entry for "speed"  with value 100.

View solution in original post

0 Kudos
2 Replies
Moderator
Moderator
575 Views
Registered: ‎09-12-2007

Re: Zynq Ultrascale+ GEM: Configuring PHY to run at 100Mbps

Jump to solution

The fixed link should work here. What are you seeing in the status registers wen using fixed link?

You could also just hack the driver, but this is a bit heavy handed

0 Kudos
Observer ndimou
Observer
712 Views
Registered: ‎05-13-2015

Re: Zynq Ultrascale+ GEM: Configuring PHY to run at 100Mbps

Jump to solution

Hi again. thanks for answering.

We managed to get it working by adding a blob for the PHY in the device tree and adding an entry for "speed"  with value 100.

View solution in original post

0 Kudos