UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor chungae9ri
Visitor
594 Views
Registered: ‎06-21-2016

Zynq uart is disabled in device tree

Jump to solution

Using custom board with zynq7000, vivado 2018.3 and petalinux 2018.3, I enabled the uart 0 (MIO 14, 15), uart 1 (MIO 12, 13) in vivado block design. After I built the image.ub, there is no petalinux console messages to my desktop terminal screen. When I check the zynq-7000.dtsi, the status of uart 0 and 1 is "disabled". Even I manually set it "okay", it is reset to "disabled" when image.ub is built. I double checked the vivado zynq7 IO configuration and it is properly enabled.

How can I change the uart 0/1 to be enabled and see the petalinux message in the serial terminal?  

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
469 Views
Registered: ‎07-31-2012

Re: Zynq uart is disabled in device tree

Jump to solution

Hi @chungae9ri ,

For  "When I check the zynq-7000.dtsi, the status of uart 0 and 1 is "disabled". Even I manually set it "okay", it is reset to "disabled" when image.ub is built. "

you need to overwrite the status to "okay" in system-user.dtsi as said earlier. Later build petalinux image and check status in system.dtb file converted to dts file.

 

"How can I change the uart 0/1 to be enabled and see the petalinux message in the serial terminal?  "

Also, you could dmesg | grep uart post linux boot to know which ttyPS* it is assigned to.

 

Refer, to https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842340/PS+UART for more checks.

 

Regards

Praveen


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
583 Views
Registered: ‎09-01-2014

Re: Zynq uart is disabled in device tree

Jump to solution
please try to set okay in system-user.dtsi.
0 Kudos
Moderator
Moderator
535 Views
Registered: ‎09-12-2007

Re: Zynq uart is disabled in device tree

Jump to solution

The devicetree generator uses the HDF to generate the devicetree automatically. So, if you have the uart enabled in the vivado, and export to SDK. this should enabled this in the devictree.

 

You can of course set this to okay in the system-user.dtsi. However, I would rather check you HDF to make sure everything is ok here.

0 Kudos
Visitor chungae9ri
Visitor
516 Views
Registered: ‎06-21-2016

Re: Zynq uart is disabled in device tree

Jump to solution

I definitely enabled the UART in my vivado design. Is there any other way to check the UART enablement in vivado design?

0 Kudos
Moderator
Moderator
502 Views
Registered: ‎09-12-2007

Re: Zynq uart is disabled in device tree

Jump to solution

Can you post your hdf file?

The device tree generator uses HSI to extract the info

You can try the following in HSI (from XSCT or HSI)

hsi::open_hw_design path/to/hdf.hdf

hsi::get_cells -filter {IS_PL==1}

You should see all the ip in the pl here. Make sure your uart is here.

 

If so, then just manually update the system-user.dtsi to enable this, and update your alias. You can also manually update the bootargs here to to add the console manually too

0 Kudos
Moderator
Moderator
501 Views
Registered: ‎09-12-2007

Re: Zynq uart is disabled in device tree

Jump to solution
0 Kudos
Highlighted
Moderator
Moderator
470 Views
Registered: ‎07-31-2012

Re: Zynq uart is disabled in device tree

Jump to solution

Hi @chungae9ri ,

For  "When I check the zynq-7000.dtsi, the status of uart 0 and 1 is "disabled". Even I manually set it "okay", it is reset to "disabled" when image.ub is built. "

you need to overwrite the status to "okay" in system-user.dtsi as said earlier. Later build petalinux image and check status in system.dtb file converted to dts file.

 

"How can I change the uart 0/1 to be enabled and see the petalinux message in the serial terminal?  "

Also, you could dmesg | grep uart post linux boot to know which ttyPS* it is assigned to.

 

Refer, to https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842340/PS+UART for more checks.

 

Regards

Praveen


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos