cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
101 Views
Registered: ‎09-26-2014

ata1: softreset failed (1st FIS failed) SATA configuration error

Hello.

I have two petalinux project. One is old, second - this working project.

I change setting in kernel, or u-boot and my SATA not work.

[ 13.573616] ata1: softreset failed (1st FIS failed)
[ 14.053471] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 330)
[ 19.217475] ata1.00: qc timeout (cmd 0xec)
[ 19.221565] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[ 19.701471] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 330)
[ 29.713471] ata1.00: qc timeout (cmd 0xec)
[ 29.717567] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[ 29.723652] ata1: limiting SATA link speed to 3.0 Gbps

I creat new project. but this dont help me.

For testing - i run same board from old u-boot and kernel. 

SATA is work.

[ 4.071366] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 330)
[ 4.078566] ata1.00: ATA-9: SFSA240GU4AA4TO-I-HC-226-STD, SBR12055, max UDMA/133
[ 4.085959] ata1.00: 468862128 sectors, multi 1: LBA48 NCQ (depth 32)
[ 4.092798] ata1.00: configured for UDMA/133
[ 4.097326] scsi 0:0:0:0: Direct-Access ATA SFSA240GU4AA4TO- 2055 PQ: 0 ANSI: 5
[ 4.105746] sd 0:0:0:0: [sda] 468862128 512-byte logical blocks: (240 GB/224 GiB)
[ 4.113246] sd 0:0:0:0: [sda] Write Protect is off
[ 4.118060] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 4.128259] sd 0:0:0:0: [sda] Attached SCSI disk

 

The board is working. I do not know how to find those settings that affect.

I ask Xilinx specialists to answer.
This is my tenth post that went unanswered.

0 Kudos