UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
4,143 Views
Registered: ‎09-02-2010

compiling the kernel

 

Hi everyone. I recentlly succeded to compile the kernel for the SP605 board, however, after reinstalling my OS and doing some other things I can no longer compile using the same procedure.

 

I have uncompressed the initramfs.cpio file into a directory and pointed the CONFIG_INITRAMFS_SOURCE parameter in the .config file to point to it. I have applied the commands (both using sudo and without it) "sudo make ARCH=microblaze mmu_defconfig", "sudo make ARCH=microblaze menuconfig" (configured the platform). I have also generated the Device Tree Source file and placed it in  "../ARCH/microblaze/boot/dts". I also set the environment variable PATH with "  export PATH="/home/arquerc/mb-gnu-tools/microblaze-unknown-linux-gnu/bin":$PATH; " which is where I have the microblaze tools placed.

 

If I am not forgetting anything I went ahead and ran "sudo make ARCH=microblaze CROSS_COMPILE=mb-linux- simpleImage.xilinx" and I got the following output:


arquerc@arquerc-UBUNTU:~/linux-2.6-xlnx$ sudo make ARCH=microblaze CROSS_COMPILE=mb-linux- simpleImage.system
make: mb-linux-gcc: Command not found
make: mb-linux-gcc: Command not found
  CHK     include/linux/version.h
  CHK     include/generated/utsrelease.h
  CC      kernel/bounds.s
/bin/sh: mb-linux-gcc: command not found
make[1]: *** [kernel/bounds.s] Error 127
make: *** [prepare0] Error 2

 

If I am correct this means that the command mb-linux-gcc can not be found and that would mean that i have incorrectlly set the PATH variable right. However if I time "echo $PATH" the value of the variable is correct....

The most alarming thing is that if i write "mb-linux-gcc" into the shell I don't get the "command not found" message... meaning that the file can actually be located....

 

I really don't know what to do... I was able to compile using this same procedure without any problems just like a week ago.

 

0 Kudos
3 Replies
Adventurer
Adventurer
4,106 Views
Registered: ‎09-02-2010

Re: compiling the kernel

Please... I really need some help....

0 Kudos
Xilinx Employee
Xilinx Employee
4,096 Views
Registered: ‎08-05-2008

Re: compiling the kernel

Did you try setting the CROSS_COMPILE information within Menuconfig

 

The tools prefix should be: microblaze-unknown-linux-gnu-

 

Hence to valiadate the tools are correctly installed try running :

shell$ microblaze-unknown-linux-gnu-gcc

You should get microblaze-unknown-linux-gnu-gcc: no input files

Then retry your build steps.

Hope this helps.

0 Kudos
Newbie kid5
Newbie
3,984 Views
Registered: ‎11-01-2010

Re: compiling the kernel

Hi!

 

I have the same problem. Could you tell me, how you solved the problem?

 

Thanks 

 

Jose

0 Kudos