cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
desulmelionel
Observer
Observer
1,503 Views
Registered: ‎06-12-2018

configure qt for petalinux 2018.1( zybo board)

I have been trying to configure qt for petalinux on my host machine in order to build a kit in qtcreator. keep running into the same error.I attached my config error. i have included the qt lib that are available in rootfs. Please any help would be greatly appreciated.

0 Kudos
2 Replies
sandeepg
Moderator
Moderator
1,457 Views
Registered: ‎04-24-2017

Hi @desulmelionel,

 

Since you are using petalinux you can follow below steps.

 

1. Enable Qt packages

$ petalinux-config -c rootfs 
---> Petalinux Package Groups
---> packagegroup-petalinux-qt
---> [*] packagegroup-petalinux-qt $ vim project-spec/meta-user/recipes-core/images/petalinux-user-image.bbappend #petalinux-user-image.bbappend content inherit populate_sdk_qt5

2. Now use the Qt5 sysroot from Qt creator to build applications.

3. Export the Qt environment variables

4. Run the Application built using Qt creator.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
lizhang86
Participant
Participant
1,247 Views
Registered: ‎04-25-2017

Hi Sandeepg,

 

Can you please kindly explain step 2 and 3?

 

Li

0 Kudos