cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
367 Views
Registered: ‎11-26-2018

petalinux 10G/25G ethernet subsystem clock configuration

Jump to solution

Hi,

I've problems to setting the clocks of the SI5328. In the system-user file I added these lines:

 

&i2c1{
	status = "okay";
	i2c-mux@74 {
		i2c@2 {
			si570_1: clock-generator@5d { /* USER SI570 - u42 */
				#clock-cells = <0>;
				compatible = "silabs,si570";
				reg = <0x5d>;
				temperature-stability = <50>;
				factory-fout = <300000000>;
				clock-frequency = <156250000>;
				clock-output-names = "si570_user";
			};
		};
		i2c@3 {
			si570_2: clock-generator@5d { /* USER MGT SI570 - u56 */
				#clock-cells = <0>;
				compatible = "silabs,si570";
				reg = <0x5d>;
				temperature-stability = <50>; /* copy from zc702 */
				factory-fout = <156250000>;
				clock-frequency = <156250000>;
				clock-output-names = "si570_mgt";
			};
		};
		i2c@4 {
			#address-cells = <1>;
			#size-cells = <0>;
			reg = <4>;
			si5328: clock-generator@69 {/* SI5328 - u20 */
				compatible = "silabs,si5328";
				reg = <0x69>;
				factory-fout = <156250000>;
				clock-frequency = <156250000>;
				clock-output-names = "si5328";
			};
		};
	};
};

but at the boot of petalinux I have this error " xilinx_axienet a0042000.ethernet eth0: XXV MAC block lock not complete! Cross-check the MAC ref clock configuration ", but if I use the program "zcu106 SCUI" the clocks are setted correctly:

clocks.JPG

 

 

 

 

 

 

 

 

At this point if I write the si5328 clock to 156.25MHz using the zcu106 SCUI I get the 10G/25G eth subsystem working (disconnecting and reconnecting the fiber cable). why doesn't it work without using the scui tool to set the si5328 clock?

 

Thanks, Andrea

 

1 Solution

Accepted Solutions
Highlighted
280 Views
Registered: ‎12-05-2019

Not sure if this will solve your problem, but I noticed that you have Si5328 at 0x69 but the user guide (UG1244 pg. 66) shows it as 0x68

 
 

https://www.xilinx.com/support/documentation/boards_and_kits/zcu106/ug1244-zcu106-eval-bd.pdf

View solution in original post

3 Replies
Highlighted
281 Views
Registered: ‎12-05-2019

Not sure if this will solve your problem, but I noticed that you have Si5328 at 0x69 but the user guide (UG1244 pg. 66) shows it as 0x68

 
 

https://www.xilinx.com/support/documentation/boards_and_kits/zcu106/ug1244-zcu106-eval-bd.pdf

View solution in original post

Highlighted
Adventurer
Adventurer
244 Views
Registered: ‎11-26-2018

Fixed by setting 0x68, the error message continues to appear.

0 Kudos
Highlighted
207 Views
Registered: ‎12-05-2019

You might want to check out this post. You'll need to patch it into the FSBL.

https://forums.xilinx.com/t5/Processor-System-Design-and-AXI/Programming-the-Si5382-on-the-ZCU111/m-p/952785

0 Kudos