UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
9,444 Views
Registered: ‎12-18-2018

petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

 

I am trying to install petalinux installer petalinux-v2018.3-final-installer.run on ubuntu 16.04.03 Desktop with RAM 8GB as normal user from /home/<username>/ folder with out root even i am facing below

errors

Error :

 

INFO: Checking installation environment requirements...
awk: read error (Bad address)

Please refer to the PetaLinux Tools Installation Guide.

Check the troubleshooting guide at the end of that manual, and if you are
unable to resolve the issue please contact customer support with file:
   /home/administrator/PETA-LINUX/petalinux_installation_log

awk: read error (Bad address)
./petalinux-v2018.3-final-installer.run: line 139: /tmp/tmp.sYPDxJkzOq/: Is a directory
ERROR: Failed to extract Petalinux installer...

Could anyone help me how to resolve this issue to continue further.

Thanks,

Raghuram

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
9,244 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

BOOT.bin actually contains FSBL+uboot. image.ub contains kernel, device tree and rootfs and we call it a FIT image

 

Best Regards

Shabbir

0 Kudos
42 Replies
Moderator
Moderator
9,364 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

 

Can you confirm if you have installed all the pre-required packages as stated in UG1144

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_3/ug1144-petalinux-tools-reference-guide.pdf

 

Best Regards

Shabbir

Adventurer
Adventurer
9,355 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

 

This error got resolved now Thanks for reply. Actually i want to install petalinux installer with proprietary license not evaluation one . Could you help me the steps how to install petalinux installer with commercial license.

 

Thanks,

Raghuram

0 Kudos
Moderator
Moderator
9,351 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

You dont need any license to install petalinux. More info here

https://www.xilinx.com/products/design-tools/embedded-software/petalinux-license.html

 

Best Regards

Shabbir 

0 Kudos
Adventurer
Adventurer
9,328 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

Thanks for reply. Actually i want to build the petalinux for zync zcu ultrascale+ 104 target board . Could you help me steps how to build and boot the target board. So far i have done below steps

1) able to run petalinux installer and able to source the environment and install the required BSP source with the below commands .

cd /home/<user-name>/peta_installer

# /petalinux-v2018.3-final-installer.run

o/P

petalinux-v2018.3-final-installer.run
INFO: Checking installation environment requirements...
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "PetaLinux SDK Installation Guide" for its impact and solution
INFO: Checking installer checksum...
INFO: Extracting PetaLinux installer...

LICENSE AGREEMENTS

PetaLinux SDK contains software from a number of sources.  Please review
the following licenses and indicate your acceptance of each to continue.

You do not have to accept the licenses, however if you do not then you may
not use PetaLinux SDK.

Use PgUp/PgDn to navigate the license viewer, and press 'q' to close

Press Enter to display the license agreements
Do you accept Xilinx End User License Agreement? [y/N] > y
Do you accept Webtalk Terms and Conditions? [y/N] > y
Do you accept Third Party End User License Agreement? [y/N] > y
INFO: Installing PetaLinux...
*********************************************
WARNING: You haven't specified the installation location.
*********************************************
*********************************************
WARNING: By default, it will be installed in your working directory: /home/tcs/PETA_LINUX/petalinux_installation
*********************************************
Please input "y" to proceed the installation, "n" to exit otherwise:y
*********************************************
WARNING: PetaLinux installation directory: /home/tcs/PETA_LINUX/petalinux_installation/. is not empty!
*********************************************
Please input "y" to continue to install PetaLinux in that directory?[n]y
INFO: Checking PetaLinux installer integrity...
INFO: Installing PetaLinux SDK to "/home/tcs/PETA_LINUX/petalinux_installation/."
INFO: Installing aarch64 Yocto SDK to "/home/tcs/PETA_LINUX/petalinux_installation/./components/yocto/source/aarch64"...
INFO: Installing arm Yocto SDK to "/home/tcs/PETA_LINUX/petalinux_installation/./components/yocto/source/arm"...
INFO: Installing microblaze_full Yocto SDK to "/home/tcs/PETA_LINUX/petalinux_installation/./components/yocto/source/microblaze_full"...
INFO: Installing microblaze_lite Yocto SDK to "/home/tcs/PETA_LINUX/petalinux_installation/./components/yocto/source/microblaze_lite"...
INFO: PetaLinux SDK has been installed to /home/tcs/PETA_LINUX/petalinux_installation/.

 

 Sudo mkdir petalinux_project
chown administrator:administrator petalinux_project
petalinux-create -t project -s /home/tcs/PETA_LINUX/petalinux-docs/xilinx-zcu104-v2018.3-final.bsp
inal.bsp
INFO: Create project:
INFO: Projects:
INFO:     * xilinx-zcu104-2018.3
INFO: has been successfully installed to /home/tcs/petalinux_project/
INFO: New project successfully created in /home/tcs/petalinux_project/


Creating Hardware Platform with Vivado
source /home/tcs/PETA_LINUX/vivado/installation/Vivado/2018.3/settings64.sh

I have done above steps and now i want to build the BSP to ZYNC 104 target board. Can you help me how to proceed further.

 

Thanks,

Raghuram

0 Kudos
Moderator
Moderator
9,324 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

Download the zcu104 bsp from website

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/embedded-design-tools.html

Here are the steps to create and build the project

petalinux-create -t project -s zcu104-bsp-file-name

cd <petalinux_project>

petalinux-build

 

0 Kudos
Adventurer
Adventurer
9,315 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

Thanks a lot for reply. I did the steps mentioned by you and struck with the below error

 

petalinux-build
[INFO] building project
[INFO] sourcing bitbake
INFO: bitbake petalinux-user-image
Loading cache: 100% |###########################################################################################################| Time: 0:00:00
Loaded 3460 entries from dependency cache.
Parsing recipes: 100% |#########################################################################################################| Time: 0:00:04
Parsing of 2569 .bb files complete (2528 cached, 41 parsed). 3461 targets, 137 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
Initialising tasks: 100% |######################################################################################################| Time: 0:00:21
Checking sstate mirror object availability: 100% |##############################################################################| Time: 0:49:15
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
WARNING: libxft-1_2.3.2-r0 do_fetch: Failed to fetch URL http://xorg.freedesktop.org/releases/individual/lib/libXft-2.3.2.tar.bz2, attempting MIRRORS if available
ERROR: libxft-1_2.3.2-r0 do_fetch: Fetcher failure: Fetch command export DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-PjGZFQxUDT"; export SSH_AUTH_SOCK="/run/user/1000/keyring/ssh"; export GIT_SSL_CAINFO="/home/tcs/PETA_LINUX/petalinux_installation/components/yocto/source/aarch64/buildtools/sysroots/x86_64-petalinux-linux/etc/ssl/certs/ca-certificates.crt"; export no_proxy="localhost,127.0.0.0/8,::1"; export NO_PROXY="localhost,127.0.0.0/8,::1"; export http_proxy="http://proxy.tcs.com:8080/"; export PATH="/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/sysroots-uninative/x86_64-linux/usr/bin:/home/tcs/PETA_LINUX/petalinux_installation/components/yocto/source/aarch64/layers/core/scripts:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/recipe-sysroot-native/usr/bin/aarch64-xilinx-linux:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/recipe-sysroot/usr/bin/crossscripts:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/recipe-sysroot-native/usr/sbin:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/recipe-sysroot-native/usr/bin:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/recipe-sysroot-native/sbin:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/recipe-sysroot-native/bin:/home/tcs/PETA_LINUX/petalinux_installation/tools/xsct/SDK/2018.3/bin:/home/tcs/PETA_LINUX/petalinux_installation/tools/xsct/SDK/2018.3/gnu/microblaze/lin/bin:/home/tcs/PETA_LINUX/petalinux_installation/tools/xsct/SDK/2018.3/gnu/aarch32/lin/gcc-arm-none-eabi/bin:/home/tcs/PETA_LINUX/petalinux_installation/tools/xsct/SDK/2018.3/gnu/armr5/lin/gcc-arm-none-eabi/bin:/home/tcs/PETA_LINUX/petalinux_installation/tools/xsct/SDK/2018.3/gnu/aarch64/lin/aarch64-none/bin:/home/tcs/PETA_LINUX/petalinux_installation/components/yocto/source/aarch64/layers/core/bitbake/bin:/home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/hosttools"; export HOME="/home/administrator"; /usr/bin/env wget -t 2 -T 30 -nv --passive-ftp --no-check-certificate -P /home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/downloads 'http://xorg.freedesktop.org/releases/individual/lib/libXft-2.3.2.tar.bz2' --progress=dot -v failed with exit code 8, output:
--2019-01-08 10:45:15--  http://xorg.freedesktop.org/releases/individual/lib/libXft-2.3.2.tar.bz2
Resolving proxy.tcs.com... 172.25.69.221
Connecting to proxy.tcs.com|172.25.69.221|:8080... connected.
Proxy request sent, awaiting response... 407 Proxy Authentication Required
2019-01-08 10:45:20 ERROR 407: Proxy Authentication Required.


ERROR: libxft-1_2.3.2-r0 do_fetch: Fetcher failure for URL: 'http://xorg.freedesktop.org/releases/individual/lib/libXft-2.3.2.tar.bz2'. Unable to fetch URL from any source.
ERROR: libxft-1_2.3.2-r0 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/tcs/petalinux_project/xilinx-zcu104-2018.3/build/tmp/work/aarch64-xilinx-linux/libxft/1_2.3.2-r0/temp/log.do_fetch.12686
ERROR: Task (/home/tcs/PETA_LINUX/petalinux_installation/components/yocto/source/aarch64/layers/core/meta/recipes-graphics/xorg-lib/libxft_2.3.2.bb:do_fetch) failed with exit code '1'

 

Could you help me how to resolve this error

 

Thanks,

Raghuram

0 Kudos
Moderator
Moderator
9,313 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

 

This is not the issue with petalinux but instead with proxy settings. You need to set the proper proxies in your build machine

There is an example GIT proxy setup here:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842401/Yocto+2017.1+Linux+Image+creation+for+ZCU102#Yocto2017.1LinuxImagecreationforZCU102-GITproxysetup:

 

Best Regards

Shabbir

0 Kudos
Adventurer
Adventurer
9,274 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Shabbir,

Thanks for your reply and I amable to build the images created the images in folder ilinx-zcu104-2018.3/images/linux/

below images

bl31.bin  image.ub     rootfs.cpio.bz2        rootfs.ext3.bz2  rootfs.jffs2     rootfs.testdata.json  u-boot.bin  zynqmp_fsbl.elf
bl31.elf  pmufw.elf    rootfs.cpio.gz         rootfs.ext4      rootfs.manifest  system.bit            u-boot.elf
BOOT.BIN  rootfs.bin   rootfs.cpio.gz.u-boot  rootfs.ext4.gz   rootfs.tar.bz2   system.dtb            uImage
Image     rootfs.cpio  rootfs.ext3            rootfs.its       rootfs.tar.gz    System.map.linux      vmlinux

Now I want boot the ZYNQ ZCU104 board using SD CARD . Could you help me which images needs to copy from above to SD card and to boot the ZYNQ ZCU 104  board .

0 Kudos
Moderator
Moderator
9,270 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

Copy BOOT.BIN & image.ub to SD card and boot

 

Best Regards

Shabbir

0 Kudos
Highlighted
Visitor minoru_aoki
Visitor
9,259 Views
Registered: ‎01-09-2019

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hello,

Could you tell me how did you resolve the first issue?

I'm now in the same kind of trouble.

Thank you,

Minoru

0 Kudos
Adventurer
Adventurer
9,251 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

For this error

 

INFO: Checking installation environment requirements...
awk: read error (Bad address)

Please refer to the PetaLinux Tools Installation Guide.

Check the troubleshooting guide at the end of that manual, and if you are
unable to resolve the issue please contact customer support with file:
   /home/administrator/PETA-LINUX/petalinux_installation_log

awk: read error (Bad address)
./petalinux-v2018.3-final-installer.run: line 139: /tmp/tmp.sYPDxJkzOq/: Is a directory
ERROR: Failed to extract Petalinux installer...

 

need to install the dependent package  gawk in ubuntu to resolve above error 

Adventurer
Adventurer
9,242 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

 I want to know whether there is no need to copy the filesystem rootfs.cpio to sdcard. 

couls you guide me actually BOOT.BIN is firstlevel bootloader right then what about uboot.bin and kernel rootfs

 

Thanks,

Raghuram

0 Kudos
Moderator
Moderator
9,245 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

BOOT.bin actually contains FSBL+uboot. image.ub contains kernel, device tree and rootfs and we call it a FIT image

 

Best Regards

Shabbir

0 Kudos
Visitor minoru_aoki
Visitor
9,227 Views
Registered: ‎01-09-2019

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

@raghuram1a wrote:

need to install the dependent package  gawk in ubuntu to resolve above error 


very helpful advice, thank you so much!

Minoru

Adventurer
Adventurer
9,188 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Shabbir,

 

Very helpful thanks very much for your support. Actually for SDcard boot to have in ZCU104 do i need to do any configure to boot from SDcard in the board. In the board is there any setting to select SDcard boot and also I want see the boot logs from minicom so which cable i need to connect to board in which place to connect to minicom serialport.

 

Thanks,

Raghuram

0 Kudos
Moderator
Moderator
9,183 Views
Registered: ‎12-04-2016

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Raghuram

 

Please refer to chapter-2 of this user guide

https://www.xilinx.com/support/documentation/boards_and_kits/zcu104/ug1267-zcu104-eval-bd.pdf

Page 12 you can find the board components. 30 is SW6, you need to configure this for boot mode SD

Refer to page 16 for various bootmode setting configurations

You can find usb-uart connecter on board to connect to minicom

 

Best Regards

Shabbir

 

 

0 Kudos
Adventurer
Adventurer
9,170 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Shabbir,

Thanks for your support and I will try this update you . Actually I want to run some Unique application which will accelerate FPGA from PS to PL in ZCU104 board. Could you suggest any use case which accelerates the FPGA PL from PS in board.

 

Thanks,

Raghuram

 

 

 

0 Kudos
Newbie witch
Newbie
9,004 Views
Registered: ‎01-14-2019

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

I also have this error(awk: read error bad address). How do you solve this problem? I will be grateful to you if you reply to me.

0 Kudos
Adventurer
Adventurer
8,871 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

 

Can you install the below  package in ubuntu PC 

package : gawk

 

0 Kudos
Contributor
Contributor
8,768 Views
Registered: ‎10-29-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Dear Sir,

All pre-required libraries are installed on my system. 

I am facing the same error. Please find the attached log file.

Looking forward for your suggestion to solve this issue.

Thank you,

Regards,

Puja Kumari

0 Kudos
Moderator
Moderator
8,754 Views
Registered: ‎04-24-2017

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi @puja,

I don't see any logs attached here.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
Contributor
Contributor
8,735 Views
Registered: ‎10-29-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Dear Sir,

While Installing petalinux on ubunut16.04, I am getting following error:

ERROR: Failed to install Yocto SDK for aarch64.

Pleae help me out to sort out this problem.

Thank you,

Regards,

Puja Kumari

0 Kudos
Adventurer
Adventurer
8,730 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Puja,

 

I think this error is due to ownership permissions to the Directory you are installing. Please change the owner ship to user instead of root the directory you are installing. 

 

 

regards,

Raghuram

 

0 Kudos
Contributor
Contributor
8,724 Views
Registered: ‎10-29-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hello Sir,

I have changed the ownership of directory where petalinux is being installed to user instead of root, but I am facing the same error still.

 

Thank you and Regards,

Puja Kumari

0 Kudos
Adventurer
Adventurer
8,715 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

Can you share the steps you followed and total error  log your getting

0 Kudos
Contributor
Contributor
8,693 Views
Registered: ‎10-29-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Dear Sir,

I am trying to install petalinux2018.2 on ubuntu 16.04.

I have downloaded the installer.  Then I am following UG976guide to install it in /opt/pkg/petalinux.

Following commands I have run : 

sudo dpkg-reconfigure dash

sudo chown -R g-testbed2/opt/pkg/petalinux

cd /opt/pkg/petalinux

chmod +x petalinux-v2018.2-final-installer.run

./petalinux-v2018.2-final-installer.run


// ERROR: You are missing the following system tools required by PetaLinux:

- xvfb-run //

sudo apt-get install xvfb

./petalinux-v2018.2-final-installer.run

// ERROR: the SDK requires the following missing utilities, please install them: g++ 
*********************************************
ERROR: Failed to install Yocto SDK for aarch64.//

sudo apt-get install g++-5

./petalinux-v2018.2-final-installer.run

 

Even though latest g++ is installed in my system, I am getting missing error for g++ and YoctoSDK for aarch 64 is not getting installed.

Please help me out.

Thank you,

Regards,

Puja Kumari

0 Kudos
Contributor
Contributor
8,671 Views
Registered: ‎10-29-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

 

 

 

 

 

 

Dear Sir,

I am trying to install petalinux2018.2. Please find below commands run by me and error I am getting it. Please help me to resolve error.

g-testbed2@gtestbed2:/opt/pkg/petalinux$ ./petalinux-v2018.2-final-installer.run
INFO: Checking installer checksum...
INFO: Extracting PetaLinux installer...

LICENSE AGREEMENTS

PetaLinux SDK contains software from a number of sources. Please review
the following licenses and indicate your acceptance of each to continue.

You do not have to accept the licenses, however if you do not then you may
not use PetaLinux SDK.

Use PgUp/PgDn to navigate the license viewer, and press 'q' to close

Press Enter to display the license agreements
Do you accept Xilinx End User License Agreement? [y/N] > y
Do you accept Webtalk Terms and Conditions? [y/N] > y
Do you accept Third Party End User License Agreement? [y/N] >
Do you accept Third Party End User License Agreement? [y/N] > y
INFO: Checking installation environment requirements...
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
INFO: Checking network and other services
INFO: Installing PetaLinux...
*********************************************
WARNING: You haven't specified the installation location.
*********************************************
*********************************************
WARNING: By default, it will be installed in your working directory: /opt/pkg/petalinux
*********************************************
Please input "y" to proceed the installation, "n" to exit otherwise:y
*********************************************
WARNING: PetaLinux installation directory: /opt/pkg/petalinux/. is not empty!
*********************************************
Please input "y" to continue to install PetaLinux in that directory?[n]y
INFO: Checking PetaLinux installer integrity...
INFO: Installing PetaLinux SDK to "/opt/pkg/petalinux/."
................................................................................................................................................................................................................................................................................INFO: Installing aarch64 Yocto SDK to "/opt/pkg/petalinux/./components/yocto/source/aarch64"...
PetaLinux Extensible SDK installer version 2018.2
=================================================
ERROR: the SDK requires the following missing utilities, please install them: g++
*********************************************
ERROR: Failed to install Yocto SDK for aarch64.
*********************************************

Please refer to the PetaLinux Tools Installation Guide.

Check the troubleshooting guide at the end of that manual, and if you are
unable to resolve the issue please contact customer support with file:
/opt/pkg/petalinux/petalinux_installation_log

Thank you,

Regards,

Puja Kumari

0 Kudos
Adventurer
Adventurer
8,654 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

 

Please try below command to resolve your issue  from the Desktop you are installing.

sudo apt-get install gcc

sudo apt-get install g++

 

0 Kudos
Adventurer
Adventurer
8,655 Views
Registered: ‎12-18-2018

Re: petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi Shabbir, 

Really Thankful to you for your support. Actuallt I want to generate .bitstream file from Petalinux and programm this generated .bitstream file to PL(fpga) of ZCU104 board while booting the board itself. Could you help me steps how to program PL from Petalinux. Waiting for youe reply

 

Thanks,

Raghuram

0 Kudos