cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jbremm
Newbie
Newbie
327 Views
Registered: ‎08-12-2020

petalinux-build error "build_with_: command not found"

Hi!

I installed PetaLinux following this quick start guide: https://github.com/Digilent/Petalinux-Zybo and everything went smooth until I tried to build the example project. I tried different shells and Ubuntu versions, also I double checked if I have all required packages installed. I tried reboot, reinstall, installing different versions (which brought more, different trouble) but nothing worked. What am I missing?

Have a great day!

 

jannick@paninigrill:~/Petalinux-Zybo/Zybo$ source /opt/pkg/petalinux/settings.shPetaLinux environment set to '/opt/pkg/petalinux'
WARNING: /bin/sh is not bash! 
bash is PetaLinux recommended shell. Please set your default shell to bash.
WARNING: This is not a supported OS
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "UG1144 2020.1 PetaLinux Tools Documentation Reference Guide" for its impact and solution
jannick@paninigrill:~/Petalinux-Zybo/Zybo$ petalinux-build
INFO: sourcing build tools
[INFO] building project
[INFO] sourcing build environment
[INFO] generating user layers
[INFO] generating workspace directory
environment: line 2760: build_with_: command not found
ERROR: Failed to build project 

 

0 Kudos
0 Replies