cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vanmierlo
Mentor
Mentor
6,932 Views
Registered: ‎06-10-2008

petalinux-config --get-hw-description fails

Jump to solution

Hi there,

 

I have a Vivado 2015.2 project for a Zynq and exported the hardware. Next I try to use this to configure petalinux 2015.2.1 with:

 petalinux-config --get-hw-description=../fpga/myproject.sdk/

This gives me the following error:

[INFO ] generate DTS to /home/..../subsystems/linux/configs/device-tree
INFO: [Common 17-206] Exiting hsi at Tue Sep 29 12:05:49 2015...
make[1]: *** [autogen-dts] Error 1
make: *** [post-config-auto-dts] Error 255
ERROR: Failed to post config linux
ERROR: Failed to config subsystem linux.
sh: lsb_release: command not found

What could I be doing wrong? I have checked I have all the required packages for CentOS7 installed.

 

Maarten

0 Kudos
1 Solution

Accepted Solutions
vanmierlo
Mentor
Mentor
12,896 Views
Registered: ‎06-10-2008

(I hate Xilinx today: I was not helped with this problem and when I found the answer and typed my extensive reply here the forum went down)

 

Yesterday I also tested on an older CentOS 6.6 and an older petalinux 2014.4 and that worked ok.

 

I was unsure if it was lsb-release that was not found or caused by a previous error. And I never would have thought it was part of an OS package instead of part of the petalinux tools.

 

So it seems lsb-release is part of 'redhat-lsb-core' and it comes in two flavours: x86_64 and i686. I installed the x86_64 variant and that seems to have done the trick. Thanks @bkamen

 

Now this package is not mentioned even in the latest UG1144 PetaLinux Tools Documentation / Reference Guide (v2015.2.1). This again makes me wonder what Supported OS: CentOS 7.0 (64 bit) means on page 9 of UG1144.

View solution in original post

0 Kudos
3 Replies
bkamen
Explorer
Explorer
6,919 Views
Registered: ‎07-17-2014
I'm on 2014.2 and don't have problems (I wrote a setup script to make sure all my ENV vars were getting set through the various settings.sh scripts.)

I'm using CentOS 6.7 (FWIW)

So the first thing I would wonder is "where is lsb_release" and why isn't it found?

on my system, "locate lsb_release" yields:

/usr/bin/lsb_release
/usr/share/man/man1/lsb_release.1.gz


are you missing a needed OS package? (maybe lsb_release is now located in another RPM?)
vanmierlo
Mentor
Mentor
12,897 Views
Registered: ‎06-10-2008

(I hate Xilinx today: I was not helped with this problem and when I found the answer and typed my extensive reply here the forum went down)

 

Yesterday I also tested on an older CentOS 6.6 and an older petalinux 2014.4 and that worked ok.

 

I was unsure if it was lsb-release that was not found or caused by a previous error. And I never would have thought it was part of an OS package instead of part of the petalinux tools.

 

So it seems lsb-release is part of 'redhat-lsb-core' and it comes in two flavours: x86_64 and i686. I installed the x86_64 variant and that seems to have done the trick. Thanks @bkamen

 

Now this package is not mentioned even in the latest UG1144 PetaLinux Tools Documentation / Reference Guide (v2015.2.1). This again makes me wonder what Supported OS: CentOS 7.0 (64 bit) means on page 9 of UG1144.

View solution in original post

0 Kudos
bkamen
Explorer
Explorer
6,900 Views
Registered: ‎07-17-2014

Glad I could help!

I'm guessing you're using 64bit Linux, so x86_64 would be the rpm to install.

And yea, Xilinx RPM packages aren't exactly the best install kits I've seen around...

And they are not great about checking for dependancies.

Again -- glad you found it.

0 Kudos