UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor chunsj
Visitor
8,638 Views

petalinux-config in 2014.2 does not run correctly.

When I run petalinux-config and exit, then following error messages appears. After

 "*** End of the configuration." message;

 

sed: -e expression #1, char 50: unknown option to `s'
sed: -e expression #1, char 56: unknown option to `s'
sed: -e expression #1, char 58: unknown option to `s'
sed: -e expression #1, char 43: unknown option to `s'
sed: -e expression #1, char 45: unknown option to `s'
sed: -e expression #1, char 69: unknown option to `s'
sed: -e expression #1, char 92: unknown option to `s'
sed: -e expression #1, char 87: unknown option to `s'
sed: -e expression #1, char 87: unknown option to `s'
....

 

I'm using petalinux-v2014.2-final on Ubinti 14.04. How can I fix this

problem?

Tags (2)
0 Kudos
42 Replies
Visitor skolinux2
Visitor
8,574 Views

Re: petalinux-config in 2014.2 does not run correctly.

I have the same problem, did you find an answer?

0 Kudos
Visitor chunsj
Visitor
8,558 Views

Re: petalinux-config in 2014.2 does not run correctly.

Unfortunately, nope.

0 Kudos
Visitor t-watanbe
Visitor
8,542 Views

Re: petalinux-config in 2014.2 does not run correctly.

i also run SDK v2014.2 on Ubuntu 14.04 LTS (64-bit), i got the same problem.

Though i executed v2014.2 on Ubuntu 12.04.4 LTS (32-bit), it worked (i attached the result of dpkg --list command). i assume this problem occurs only on 64-bit or v2014.2 does not run on Ubuntu 14.04.

0 Kudos
Highlighted
Visitor chunsj
Visitor
8,531 Views

Re: petalinux-config in 2014.2 does not run correctly.

It seems that petalinux only tested in 32bit env. And petalinux-config binary is 32bit too.
0 Kudos
Visitor nymitr
Visitor
8,494 Views

Re: petalinux-config in 2014.2 does not run correctly.

Same problem on 64bit ArchLinux.

0 Kudos
Visitor chunsj
Visitor
8,488 Views

Re: petalinux-config in 2014.2 does not run correctly.

It seems that petalinux-config in 2014.2 does have problem in 64 bit linux. Do you hear me xilinx? :-)

0 Kudos
Xilinx Employee
Xilinx Employee
8,477 Views

Re: petalinux-config in 2014.2 does not run correctly.

Hi,

 

Did you install all the required tools and libraries as documented in the install guide? 

 

I have seen a different issue I don't understand yet, but not the same as yours.

 

Thanks

John

0 Kudos
Visitor skolinux2
Visitor
8,461 Views

Re: petalinux-config in 2014.2 does not run correctly.

Hi I am using the 32bit version of Ubuntu and have just double checked the lib install against that given on page 10 of the install guide. The libs are all there and up to date except for the 32 bit libs which it says it can’t find. I googled that and think I have now installed them but I am still getting the sed error.  Xilinx tools just don’t seem to work for me and I have spent many weekends trying!

 

0 Kudos
Visitor t-watanbe
Visitor
8,445 Views

Re: petalinux-config in 2014.2 does not run correctly.

What error occurred? Why don't you paste the result of "tail -10 build/build.log"?

e.g., "bc" package is required to build your kennel.
if you use a new version of Ubuntu 64-bit, "primus-libs-ia32" package is required instead of "ia32-libs".

FYI, here is my instruction to execute PetaLinux SDK on Ubuntu:
sudo apt-get install primus-libs-ia32 bc tofrodos iproute gawk gcc \
 git-core build-essential make net-tools ncurses-dev tftpd-hpa \
 zlib1g-dev flex bison lib32ncursesw5 lib32ncurses5 lib32gomp1

0 Kudos
Visitor chunsj
Visitor
7,813 Views

Re: petalinux-config in 2014.2 does not run correctly.

build.log says;

 

[INFO ] config linux
[INFO ] generate DTS to /home/chunsj/Documents/AMP03/Linux/subsystems/linux/configs/device-tree
[INFO ] generate linux/u-boot board header files
[INFO ] generate BSP for zynq_fsbl
[INFO ] oldconfig linux/kernel
[INFO ] oldconfig linux/rootfs
[INFO ] config linux

and the terminal executing petalinux-config keeps saying;

 

sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 24: unknown option to `s'
sed: -e expression #1, char 24: unknown option to `s'
sed: -e expression #1, char 24: unknown option to `s'
sed: -e expression #1, char 24: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
sed: -e expression #1, char 25: unknown option to `s'
...

 

 

0 Kudos
7,777 Views

Re: petalinux-config in 2014.2 does not run correctly.

I am trying to use Mint 17 to configure petalinux-v2014.2. I get a very similar error. The config.log has:

 

*
* Firmware Version Configuration
*
Host name (SUBSYSTEM_HOSTNAME) [Avnet-Digilent-ZedBoard-2014_2]
Product name (SUBSYSTEM_PRODUCT) [Avnet-Digilent-ZedBoard-2014.2]
Firmware Version (SUBSYSTEM_FW_VERSION) [1.00]
#
# configuration written to /media/sf_S_DRIVE/tcplib/Avnet-Digilent-ZedBoard-2014.2/subsystems/linux/config
#
sed: -e expression #1, char 42: unknown option to `s'
sed: -e expression #1, char 46: unknown option to `s'
sed: -e expression #1, char 50: unknown option to `s'
sed: -e expression #1, char 83: unknown option to `s'
sed: -e expression #1, char 42: unknown option to `s'
sed: -e expression #1, char 162: unknown option to `s'
sed: -e expression #1, char 31: unknown option to `s'
sed: -e expression #1, char 26: unknown option to `s'
sed: -e expression #1, char 45: unknown option to `s'
sed: -e expression #1, char 26: unknown option to `s'
sed: -e expression #1, char 54: unknown option to `s'
sed: -e expression #1, char 26: unknown option to `s'

 

and continues with similar error messages. The terminal window says:

 

[INFO ] config linux/rootfs


*** End of the configuration.


make: Warning: File `/media/sf_S_DRIVE/tcplib/Avnet-Digilent-ZedBoard-2014.2/build/linux/rootfs/Makefile.export' has modification time 0.53 s in the future
make: warning: Clock skew detected. Your build may be incomplete.
sed: -e expression #1, char 42: unknown option to `s'
sed: -e expression #1, char 46: unknown option to `s'
sed: -e expression #1, char 50: unknown option to `s'

and so on.

 

Any idea what I should check?

 

0 Kudos
Visitor patrick.knox
Visitor
7,644 Views

Re: petalinux-config in 2014.2 does not run correctly.

Any update to this issue I'm still unable to configure petalinux 2014.2 in ubuntu 14.04.

0 Kudos
Visitor chunsj
Visitor
7,641 Views

Re: petalinux-config in 2014.2 does not run correctly.

I cannot figure out any solution on this yet; just have reverted back to old, but working combo - Vivado 2013.4 + Petalinux 2013.10.

0 Kudos
Visitor nlantz
Visitor
7,629 Views

Re: petalinux-config in 2014.2 does not run correctly.

Hi,

I have the same problem...


Xilinx, is it possible to have access to the source code of the peta-linux tools to correct the bug ?

Thanks

0 Kudos
7,594 Views

Re: petalinux-config in 2014.2 does not run correctly.

Same issue for Fedora 20 64-bit.  Any fix or workaround yet?

0 Kudos
Visitor nlantz
Visitor
7,566 Views

Re: petalinux-config in 2014.2 does not run correctly.

No fix or workaround, but i try to debug the problem :

 

I have created a script named : sed in ~/WORK/PROJECT/ZedBoard/bin :

#!/bin/bash
echo "argument : $*" >>~/WORK/PROJECT/ZedBoard/Log.txt
/bin/sed $* 2>>~/WORK/PROJECT/ZedBoard/Log.txt

 

Just before launch petalinux-config i export the script directory in PATH to override the real sed binary :

PATH="~/WORK/PROJECT/ZedBoard/bin:$PATH"

 

and then we have the log of the sed call that cause the error in ~/WORK/PROJECT/ZedBoard/Log.txt :

...

argument : s/hw-description/hw-description.tcl:            } else {==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                for {set i 0} {$i < 32} {incr i} {==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    set idmap [list "${bankidreplacement}" ${i}]==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    set basestrmap [string map ${idmap} "${bank_baseaddr_property}"]==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    set highstrmap [string map ${idmap} "${bank_highaddr_property}"]==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    set typestrmap [string map ${idmap} "${bank_type_property}"]==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    set bankenablemap [string map ${idmap} "${bank_enabled_property}"]==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    set bankenabled [get_property ${bankenablemap} ${hd}]==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                    if {"${bankenabled}" ==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée
argument : s/hw-description/hw-description.tcl:                        break==//g
/bin/sed: -e expression n°1, caractère 36: commande `s' inachevée

...

 

It seem that sed is called with an argument containing "/hw-description/hw-description.tcl:"  concatenated with each line of the    test-project/build/linux/hw-description/hw-description.tcl script itself.

Please Xilinx ?

 

0 Kudos
7,470 Views

Re: petalinux-config in 2014.2 does not run correctly.

Has anyone opened a webcase on this yet?  Our development is at a standstill until we can get at least a workaround for this.  I really don't want to install old versions of stuff just to get it working.  With nlantz's debugging hints, someone who knows the code should be able to fix this pretty quickly, I would think.  Sounds like reproducing the problem is pretty easy.

0 Kudos
Xilinx Employee
Xilinx Employee
7,463 Views

Re: petalinux-config in 2014.2 does not run correctly.

We've been seeing this a bit on unsupported OS's -- namely Ubuntu (and those based on it) and bleeding edge Fedora (19/20) .

 

We've begun some initial investigations into this but cannot reproduce it on supported OS's or shells so I cannot currently offer any kind of workaround/fix other than to use a supported OS as listed in the PetaLinux install guide.

-------------------------------------------
this space intentionally left blank
0 Kudos
7,456 Views

Re: petalinux-config in 2014.2 does not run correctly.

Thanks for the reply, tmcdowe.  I appreciate your looking into this and also your viewpoint.  One comment is that it would be nice if there was just one free Linux distro in the officially supported list.  Pick whatever you want, and I will happily install that, but I can't justify purchasing RedHat or SUSE just to reconfig petalinux.

 

Do you have an estimate for a fix and/or an idea of which most recent Fedora does not have the problem?  Or, as nlantz suggested, could you allow some small access to the code so we can assist with debugging?  We have narrowed it down to an improperly formated regular expression substitution passed to sed.  I'm going to guess it will involve a tiny tweak to a script somewhere, but I can't tell what is making the improper sed call as some of the code is compiled.

 

Thanks.

 

0 Kudos
Xilinx Employee
Xilinx Employee
9,087 Views

Re: petalinux-config in 2014.2 does not run correctly.

Our engineering staff are aware of this so if their is a straightforward fix, it will be published as an AR.

 

Also, we are currently investigating supporting additional OS's -- namely Ubuntu and CentOS -- for an upcoming release of PetaLinux.

-------------------------------------------
this space intentionally left blank
0 Kudos
9,081 Views

Re: petalinux-config in 2014.2 does not run correctly.

Thanks for the info.  Sounds promising.

0 Kudos
Visitor chunsj
Visitor
9,075 Views

Re: petalinux-config in 2014.2 does not run correctly.

To me, it's matter of fixing sed script; can you change separator of sed script something other than '/', so that / character in path be not collided with separator of sed script?

 

Though I've downgraded the whole toolset and cannot test this, maybe create sed wrapper doing this might work around this problem.

0 Kudos
Visitor nlantz
Visitor
9,002 Views

Re: petalinux-config in 2014.2 does not run correctly.

I've installed a CentOS 6.5 (equivalent to RedHat 6.5 but free) in a virtual machine (under virtualbox) and it's working:
https://centos.org/download/

But it's not a satisfying solution for me as it complicates a lot the developpement.

 


Message to the xilinx managers/decision-makers :

We are in 2014 and you can't always say "use a supported OS". We can't buy a workstation only for xilinx Tools.

If you are not able to correctly support your tools under very common OS like Ubuntu, please open your source-code. All developpers will be happy to help Xilinx to improve the developpement flow (instead to be at a standstill !!).

Petalinux is a 1% closed source tool above 99% of open source components. This situation is ridiculous.

 

 

Newbie kevinchen
Newbie
8,863 Views

Re: petalinux-config in 2014.2 does not run correctly.

'petalinux-config' in 2014.2 does not run correctly after installed under OpenSUSE 13.1 64-bit. Same sed unknown option issue.
 
Do I have to use the OpenSUSE Enterprise 11 for version 2014.2 to work?

 

 

 

0 Kudos
Visitor i.panchenko
Visitor
8,808 Views

Re: petalinux-config in 2014.2 does not run correctly.

Have same errors! Please, fix it or release 2014.5 ASAP!

0 Kudos
8,691 Views

Re: petalinux-config in 2014.2 does not run correctly.

This seem to indicate that the result of a grep is passed to sed (grep sometimes prefixes the matched lines with the file name). And indeed compiling the same version of grep as Centos 6 (grep 2.6.3) and installing it in a directory added to the PATH before running petalinux-config seem to do the trick.

Observer eengie
Observer
8,659 Views

Re: petalinux-config in 2014.2 does not run correctly.

Gilles,

 

That note about grep managed to get me slightly farther on Mint 17.

 

Having downloaded grep 2.6.3 tarball, I configured it to use the ./tools/common/petalinux path as its installation directory (./configure --prefix=<path>).  That way the petalinux settings.sh script would automatically configure the path to use the "right" grep.  However, now I get the following error as petalinux-configure exits:

 

/bin/sh: 1: pushd: not found

/bin/sh: 1: popd: not found

make: *** [post-config-auto-config] Error 127

ERROR: Failed to post config linux

ERROR: Failed to config component linux

 

Did you have to do anything else to have grep resolve the problem?  Reinstall the petalinux tools or something along those lines?

0 Kudos
Observer eengie
Observer
8,651 Views

Re: petalinux-config in 2014.2 does not run correctly.

Actually, it looks like the petalinux scripts/tools are somehow electing to use /bin/sh rather than /bin/bash. When I run settings.sh, it warns me that I'm not using bash (incorrect, I am using bash). So there seems to be something goofed up there.

Does anyone have an idea how to convince petalinux to use /bin/bash?
0 Kudos
Newbie paserra
Newbie
8,648 Views

Re: petalinux-config in 2014.2 does not run correctly.

Just chage /bin/sh to point to /bin/bash. Something like this

sudo rm /bin/sh
sudo ln -s /bin/bash /bin/sh

 

0 Kudos