UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor micelic
Visitor
3,330 Views
Registered: ‎09-19-2013

petalinux-install-bsp license problem

Has anyone received the following error after installing Petalinux ... receive a license... moved the license in the .Xilinx directory and tried to install a bsp ?

 

petalinux-default-bsp
ERROR: No valid PetaLinux features! Typical causes for this error are
either that there is no license file or that license files, which were
found, do not contain a valid license with the required feature.

I also entered this  command with the bsp file after it ... no difference.

 

If I run XLCM the 3 petalinux licenses show up but hostid match show NO... But the area below the list shows the same hostid that is in my license file.

 

Any help would be greatly appreciated.

 

Thanks,

Carlo

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
3,316 Views
Registered: ‎04-16-2012

Re: petalinux-install-bsp license problem

Hi,

 

Check this AR: http://www.xilinx.com/support/answers/56505.htm

 

Thanks

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Visitor micelic
Visitor
3,290 Views
Registered: ‎09-19-2013

Re: petalinux-install-bsp license problem

Thanks but problem solved.

 

Must have a eth0 interface... Petalinux license is looking for the MAC address for eth0.

 

Since I have a new dell computer and running Red Hat 6... Dell introduced a new way of naming their ethernet drivers based on pci bus number etc...

 


There is a dell document that describes how to put it back to the traditional way eth0,, Once I did this the license manager worked.

0 Kudos