UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
6,994 Views
Registered: ‎03-05-2015

petalinux root filesystem type

Hey,

 

I'm a bit stuck with petalinux running on my zynq 7000. 

I'm able to run petalinux on it but when I reboot my processor all my files/changes are reset.

I use in petalinux-config the advanced bootable image storage settings and turned boot image/kernel image and drb image to primary sd. After this the files were still removed after reset. So I tried to use the petalinux-config and turn the root filesystem type to sd but then the petalinux doesnt run anymore (not even u-boot). 

 

Any ideas how to fix this? thx!

 

0 Kudos
2 Replies
6,993 Views
Registered: ‎03-05-2015

Re: petalinux root filesystem type

I forgot to say that i run this petalinux on a single partition sd card with fat32 system

0 Kudos
Scholar rfs613
Scholar
6,977 Views
Registered: ‎05-28-2013

Re: petalinux root filesystem type

In the default setup provide by Xilinx, the Zynq boots into a RAM disk. Thus any changes you make will be lost after rebooting.

There are many possible solutions. This is very much a FAQ, search the forum and you will find many discussion threads. In no particular order, your options include:

- Mount the SD card and store your data there
- Modify an existing ramdisk (on your PC) to include your files (http://www.wiki.xilinx.com/Build+and+Modify+a+Rootfs)
- Adjust petalinux so it include your programs/data into the ramdisk that it builds
- Don't use a ramdisk at all. Switch to a filesystem like JFFS2 or UBIFS instead. This would be for NOR or NAND flash, not so much for SD card.

0 Kudos