UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
61 Views
Registered: ‎07-06-2016

"ERROR: No package mode has been specified" after update hdf

Jump to solution

Hello,

I updated my existing bsp petalinux project with a new hdf file generated in vivado running:

petalinux-config--get-hw-description=<PATH-TO-HDF/DSA-DIRECTORY>

When I run this comand (which before worked):

petalinux-package -- boot --fsbl zynqmp_fsbl.elf --u-boot u-boot.elf --fpga system.bit 

I've got the next error:

This command packages various image format, prebuilt
and bsps
Usage:
  petalinux-package --boot|--bsp|--image|--prebuilt|--sysroot [options]

Required:
  --boot|--bsp|--image|--prebuilt|--sysroot
                               Various package mode.
                                 boot: packages a boot.bin for Zynq
                                 bsp: packages a bsp
                                 image: package various image type
                                 prebuilt: package images to prebuilt
				 sysroot: Install sdk
Options:
  -h|--help                    Display help messages
Please specify a package mode option for the detailed options
Show package boot options:
  $ petalinux-package --boot --help

Show package bsp options:
  $ petalinux-package --bsp --help

Show package image options:
  $ petalinux-package --image --help

Show package prebuilt options:
  $ petalinux-package --prebuilt --help

Show package sysroot options:
  $ petalinux-package --sysroot --help

ERROR: No package mode has been specified.

Any ideas what could it be?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
38 Views
Registered: ‎02-07-2018

Re: "ERROR: No package mode has been specified" after update hdf

Jump to solution

HI @joseer 

Looks in your case you have specified extra space before boot option(-- boot). You no need to speicfy.

 

For your reference please use this below commands to configure & build for zynqMP.

petalinux-config --get-hw-description=/<HDF PATH>/

petalinux-build

petalinux-package --boot --fsbl images/linux/zynqmp_fsbl.elf --fpga images/linux/system.bit --pmufw images/linux/pmufw.elf --u-boot --force

For zynq : 

petalinux-package --boot --fsbl <FSBL image> --fpga <FPGA bitstream> --u-boot

 

Thanks & ergards

Aravind

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

 

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
39 Views
Registered: ‎02-07-2018

Re: "ERROR: No package mode has been specified" after update hdf

Jump to solution

HI @joseer 

Looks in your case you have specified extra space before boot option(-- boot). You no need to speicfy.

 

For your reference please use this below commands to configure & build for zynqMP.

petalinux-config --get-hw-description=/<HDF PATH>/

petalinux-build

petalinux-package --boot --fsbl images/linux/zynqmp_fsbl.elf --fpga images/linux/system.bit --pmufw images/linux/pmufw.elf --u-boot --force

For zynq : 

petalinux-package --boot --fsbl <FSBL image> --fpga <FPGA bitstream> --u-boot

 

Thanks & ergards

Aravind

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

 

0 Kudos