cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
690 Views
Registered: ‎08-02-2016

selected processor does not support ARM mode `isb'

hi, Experts

I am working on AVNET picozed following the https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841616/Zynq+Base+TRD+2015.4. The default operation is to generate uboot, kernel , dts, ramfs on SD card, but now I am trying to generate BOOT.bin & image.ub based on the demo petalinux project,  and boot up from SPI flash + EMMC mode.

What I have done are shown below:

  • petlinux-config -> ...-> boot image settings : choose primary flash
  • petlinux-config -> ... -> kernel image settings: choose primary SD
  • petalinux-config -> Auto config settings: select kernel auto config / rootfs auto config / u-boot auto config;
  • petalinux-config -> u-boot configuration -> u-boot config : choose petalinux u-boot config, also set proper netboot offset value;
  • adjust flash partition size, as the BOOT.bin is larger than default size.

Then I run petalinux-build, when building kernel, it reported as:

[ERROR] make[4]: *** [arch/arm/mach-zynq/lowlevel_init.o] Error 1
[ERROR] make[3]: *** [arch/arm/mach-zynq] Error 2
[ERROR] make[2]: *** [sub-make] Error 2

And the ./build/build.log file reported error:

[ALL ] /home/mcggoal/xlnx_project/pzfmc2_bgslib/petalinux/build/linux/u-boot/src/u-boot-plnx/arch/arm/mach-zynq/lowlevel_init.S: Assembler messages:
[ALL ] /home/mcggoal/xlnx_project/pzfmc2_bgslib/petalinux/build/linux/u-boot/src/u-boot-plnx/arch/arm/mach-zynq/lowlevel_init.S:18: Error: selected processor does not support ARM mode `isb'
[ALL ] /home/mcggoal/xlnx_project/pzfmc2_bgslib/petalinux/build/linux/u-boot/src/u-boot-plnx/scripts/Makefile.build:312: recipe for target 'arch/arm/mach-zynq/lowlevel_init.o' failed

Can anybody give suggestions on this ?

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
641 Views
Registered: ‎09-14-2018

Hi , @mcggoal 

What are the commands you created this Petalinux project and get the HDF file with? 

Maybe you created your project with zynqMP template but souced a zynq7000 HDF file?

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

0 Kudos
Highlighted
Contributor
Contributor
618 Views
Registered: ‎08-02-2016

@chaoz  thanks for reply.

I did not create project using command , I just copied it from "petalinux folder" in DEMO package, then using petalinux-config --get-hw-description = ./hw-description, so it's sure to use the correct CPU. 

What I want is just change options in petalinux-config window and build BOOT.bin and image.ub for QSPI+EMMC bootup.

0 Kudos
Highlighted
Contributor
Contributor
604 Views
Registered: ‎08-02-2016

@chaoz I have got thru this error, that is caused by the unnecessary environment variable setting, which is used for OPENCV cross-compilation.

But, the building process still fault at further step, the error log shows:

[ALL ] arch/arm/kernel/built-in.o: In function `cpu_resume':
[ALL ] arch/arm/kernel/hyp-stub.o:(.data+0x2fc): relocation truncated to fit: R_ARM_CALL against symbol `__hyp_stub_install_secondary' defined in .text section in arch/arm/kernel/built-in.o
[ALL ] /home/mcggoal/xlnx_project/pzfmc2_spi_emmc/petalinux/components/linux-kernel/xlnx-4.0-python/Makefile:933: recipe for target 'vmlinux' failed
[ERROR] make[4]: *** [vmlinux] Error 1

I think it maybe caused by large rootfs size, because my rootfs size is larger than 90MB.

Do you have any suggestion on this ? how can I build a large image ?

0 Kudos