UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
4,637 Views
Registered: ‎07-21-2008

I got the problem in dumping the code in v2pro

iam taking simple example like led blinking , iam coonected rs233 and jtag cable it reults error

 after generating the bit file like this how to configure the v2 pro my  sw 8  isall switches are  up  sw9 all switches are down and one more thing is after getting power on the system ACe led D11 blinking status error repotred how i avoid this problem

 

********************************************
Downloading Bitstream onto the target board
*********************************************
impact -batch etc/download.cmd
Release 10.1.02 - iMPACT K.37 (nt)
Copyright (c) 1995-2008 Xilinx, Inc.  All rights reserved.
Preference Table
Name                 Setting            
StartupClock         Auto_Correction    
AutoSignature        False              
KeepSVF              False              
ConcurrentMode       False              
UseHighz             False              
ConfigOnFailure      Stop               
UserLevel            Novice             
MessageLevel         Detailed           
svfUseTime           false              
SpiByteSwap          Auto_Correction    
AutoDetecting cable. Please wait.
Connecting to cable (Parallel Port - LPT1).
Checking cable driver.
 Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS
12:35:07, version = 811.
 LPT base address = 0378h.
 ECP base address = 0778h.
Cable connection failed.
Connecting to cable (Parallel Port - LPT2).
Checking cable driver.
 Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS
12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Parallel Port - LPT3).
Checking cable driver.
 Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS
12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Parallel Port - LPT4).
Checking cable driver.
 Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS
12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Driver file xusbdfwu.sys found.
 Driver version: src=1027, dest=1027.
 Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS
12:35:07, version = 811.
 Cable PID = 0008.
 Max current requested during enumeration is 150 mA.
Type = 0x0605.
 Cable Type = 3, Revision = 0.
 Setting cable speed to 6 MHz.
Cable connection established.
Firmware version = 1027.
File version of c:/Xilinx/10.1/ISE/data/xusbdfwu.hex = 1028.
Firmware hex file version = 1028.
Downloading c:/Xilinx/10.1/ISE/data/xusbdfwu.hex.
Downloaded firmware version = 1028.
PLD file version = 0012h.
 PLD version = 0012h.
Identifying chain contents ....'1': : Manufacturer's ID =Xilinx xc2vp30, Version : 1
INFO:iMPACT:1777 -
   Reading c:/Xilinx/10.1/ISE/virtex2p/data/xc2vp30.bsd...
----------------------------------------------------------------------
----------------------------------------------------------------------
'2': : Manufacturer's ID =Xilinx xccace, Version : 0
INFO:iMPACT:501 - '1': Added Device xc2vp30 successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
'3': : Manufacturer's ID =Xilinx xcf32p, Version : 15
INFO:iMPACT:1777 -
   Reading c:/Xilinx/10.1/ISE/acecf/data/xccace.bsd...
INFO:iMPACT:501 - '1': Added Device xccace successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
INFO:iMPACT:1777 -
   Reading c:/Xilinx/10.1/ISE/xcfp/data/xcf32p.bsd...
INFO:iMPACT:501 - '1': Added Device xcf32p successfully.
done.
Elapsed time =      0 sec.
Elapsed time =      0 sec.
'2': Loading file 'implementation/download.bit' ...
done.
----------------------------------------------------------------------
----------------------------------------------------------------------
----------------------------------------------------------------------
INFO:iMPACT:501 - '2': Added Device xc2vp30 successfully.
INFO:iMPACT:583 - '2': The idcode read from the device does not match the idcode
   in the bsdl File.
INFO:iMPACT:1578 - '2':  Device IDCODE :        00000000000000000000000000000000
INFO:iMPACT:1579 - '2': Expected IDCODE:    00000001001001111110000010010011
Elapsed time =      0 sec.
----------------------------------------------------------------------
----------------------------------------------------------------------
----------------------------------------------------------------------
----------------------------------------------------------------------
make: *** [download] Error 1
Done!

 

 

 

0 Kudos
1 Reply
Observer ifen_gmbh
Observer
4,616 Views
Registered: ‎07-11-2008

Re: I got the problem in dumping the code in v2pro

Hi,

 

we have had a similar problem with the different IDCODEs

The problem was, that the JTAG connector wasn't soldered correctly. The device was identified, but it wasn't possible to program.

So, check the connector on the PCB.

 

Best regards, Nico 

0 Kudos