UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
6,264 Views
Registered: ‎02-13-2012

Linux can not get start on the zed board

Hello every one ,

         

      The linux system cannot get start on my board.

       

      There are logs printed through the serial port

U-Boot 2012.04.01-00304-g7639205 (May 11 2013 - 15:43:39)

DRAM:  512 MiB
WARNING: Caches not enabled
MMC:   SDHCI: 0
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   zynq_gem
Hit any key to stop autoboot:  0
Copying Linux from SD to RAM...
Device: SDHCI
Manufacturer ID: 12
OEM: 3456
Name: F0F0F
Tran Speed: 25000000
Rd Block Len: 512
SD version 2.0
High Capacity: Yes
Capacity: 3.7 GiB
Bus Width: 4-bit
reading zImage

2483504 bytes read
reading devicetree.dtb

5793 bytes read
reading ramdisk8M.image.gz

3622263 bytes read
## Starting application at 0x00008000 ...
Uncompressing Linux... done, booting the kernel.

           the system stopped here , booting the kernel failed.

 

           What's the reason causing this kind of problem..

 

          Hoping your help!

 

SXL

       

0 Kudos
6 Replies
Adventurer
Adventurer
6,258 Views
Registered: ‎02-13-2012

Re: Linux can not get start on the zed board

I have done some trial. And I make sure that the kernel is ok. Because it works well with the official BOOT.BIN file.

 

But when using my BOOT.BIN file , it never works . 

and the system stop at here:

## Starting application at 0x00008000 ...
Uncompressing Linux... done, booting the kernel.

 

The difference in the serial log file between the two situation is that

MY:

SD version 2.0
High Capacity: Yes
Capacity: 3.7 GiB
Bus Width: 4-bit

HIS:

 

SD version 1.0
High Capacity: Yes
Capacity: 3.7 GiB
Bus Width: 1-bit

 

I am not sure if it is the problem.

 

Anybody may give me some advice??

 

SXL

 

0 Kudos
Scholar austin
Scholar
6,250 Views
Registered: ‎02-27-2008

Re: Linux can not get start on the zed board

Have you asked on zedboard.com?

 

That is the official support for the zedboard community.

 

Of course, you are welcome to ask here, also.

 

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Adventurer
Adventurer
6,241 Views
Registered: ‎02-13-2012

Re: Linux can not get start on the zed board

I have posted on the www.zedboard.org.

 

I have tried several methods, but I cannot find the reason why I am wrong..

 

 

SXL

0 Kudos
Adventurer
Adventurer
6,239 Views
Registered: ‎02-13-2012

Re: Linux can not get start on the zed board

I suppose the BOOT.BIN file is the source of the error.

 

The BOOT.BIN is made up of the fsbl.elf, u-boot.elf and system.bit file. I have downloaded the system.bit file to the zynq , It successed.

 

So only the fsbl.elf and the u-boot.elf could be wrong.

0 Kudos
Adventurer
Adventurer
6,237 Views
Registered: ‎02-13-2012

Re: Linux can not get start on the zed board

 

 

I find another phonomenon: sometimes the BOOT.BIN file can configure the PL fabric.

 

                                                   sometimes it cannot.

 

I don't know why. For I use the same system.bit file

 

 

And I compared my generated BOOT.BIN file with the official file. The size of my is 4226KB, his is 4247KB. Dose this make sense.

 

Hoping your help!

 

SXL

0 Kudos
Observer qswsjs
Observer
5,608 Views
Registered: ‎07-18-2013

Re: Linux can not get start on the zed board

Hi,

Have you solved the problem ? I get the same problem,can you give me some advice ?thankyou!

0 Kudos