UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor kganesh90
Visitor
1,597 Views
Registered: ‎02-28-2017

Programming FPGA from rc.local on Linux.

Hi everyone. I'm trying to boot up the Linux on the Zynq Zturn board with the bitstream in the rc.local. But unable to do so. These are the steps I follow. 

 

      1. I generate the <name>.bit.bin file from bootgen. 

      2. copy the file to the SD card. 

      3. I have put cat /path/to/design_1_wrapper.bit.bin > /dev/xdevcfg in the rc.local of linux.

      4. Reboot 

 

I expect the PL to be programmed on next boot up. Though the done light is on and cat /sys/devices/amba.0/f8007000.devcfg/prog_done shows 1, the applciation I run with it does not run the way I expect. Bu if I run cat /path/to/design_1_wrapper.bit.bin > /dev/xdevcfg manually from linux command line, the FPGA is programmed and application runs just fine. 

 

Am I doing any mistake? Please give your inputs. 

 

 

 

 

0 Kudos