UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor tthomto
Visitor
406 Views
Registered: ‎10-18-2018

UART not working when using SD or flash boot

Jump to solution

Using my zturn board, I am trying to read and output the sensor data through serial terminal. I am able to receive output on the putty terminal once I program my FPGA and run/debug my software code. When I tried to boot from SD card, i am getting the signal at the ports. However, I am not getting an output on the terminal. The same happens when I try to boot through flash. The software side is not working. Please help. 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor tthomto
Visitor
230 Views
Registered: ‎10-18-2018

Re: UART not working when using SD or flash boot

Jump to solution

Including DDR on my hardware design helped me to get rid of those warnings. Now I am able to get data through UART.

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
340 Views
Registered: ‎09-01-2014

Re: UART not working when using SD or flash boot

Jump to solution
Uart is working when loading SW via JTAG but didn’t work in SD or QSPI boot mode.
SD or QSPI boot needs an FSBL, do you change something in the FSBL?
0 Kudos
Visitor tthomto
Visitor
334 Views
Registered: ‎10-18-2018

Re: UART not working when using SD or flash boot

Jump to solution

Hi, thanks for the reply. Whenever I add a new ZYNQ_FSBL application into the project, i am getting the following warnings.

fsbl.PNG

Even though those were the warnings, I still used this fsbl to create the image. The board was not even booting in this case.

So I used the zynq fsbl fiile from my old Hello World program to boot the board. I was able to get the output signals from the board. However, UART was not working in this case.

 

0 Kudos
Highlighted
Visitor tthomto
Visitor
231 Views
Registered: ‎10-18-2018

Re: UART not working when using SD or flash boot

Jump to solution

Including DDR on my hardware design helped me to get rid of those warnings. Now I am able to get data through UART.

0 Kudos