UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
112 Views
Registered: ‎02-13-2016

Ultra96 Serial Connection does not work

Hello,

I have got my brand new Ultra96. It boots fine and I am able to access the terminal on Putty using SSH. When it comes to using serial connections, it does not work at all. It connects then the terminal is totally blank without anything (suppose to have the message of "Login as:", but never happened). I tried it on Ubuntu 16.04 and on Windows 7. The board itself boots successfully as I was able to login to the system and even could run some linux commands, but as I mentioned, this happens only through the SSH using the IP address of the board.

 

The UART/JTAG is detected on both OS, and here is the log from Ubutunu 16.04:

[78178.484705] usb 2-1.3: FTDI USB Serial Device converter now attached to ttyUSB0
[78178.486791] usb 2-1.3: FTDI USB Serial Device converter now attached to ttyUSB1

Bus 002 Device 010: ID 0403:6010 Future Technology Devices International, Ltd FT2232C Dual USB-UART/FIFO IC

 

when I ran the command (dmesg | grep tty) on the board itself, this was the output

root@Ultra96:~# dmesg | grep tty
[    0.012541] console [tty0] enabled
[    1.399594] 80060000.serial: ttyS2 at MMIO 0x80061000 (irq = 45, base_baud = 6249993) is a 16550A
[    1.400242] ff000000.serial: ttyPS1 at MMIO 0xff000000 (irq = 39, base_baud = 6249993) is a xuartps
[    1.400561] ff010000.serial: ttyPS0 at MMIO 0xff010000 (irq = 40, base_baud = 6249993) is a xuartps
[    2.402036] console [ttyPS0] enabled

So, is there some configurations I have to do in order to have the serial communication works?

 

Thanks

0 Kudos