UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
483 Views
Registered: ‎04-19-2016

xapp585 cameralink decoder 'one' pixel shift to right after the 16th pixel in the first line

Hello,

 

I took the app note Xapp585 to build a Cameralink receiver and transmitter IP.  I implemented the Cameralink receiver IP, it seems that work properly, except the first line. The others lines are received and decoded correctly. I have realized that, there is a problem in the first line. Up to 16th pixel (16 included) is received correctly.  But after the this 16th pixel, 17th pixel is zero and then correct values comes. However, 17th pixel should have not to be zero. there is only 'one' pixel shift to the right, in only first line after the 17th pixel. I have used a FIFO, and I take fifo out to a Axi-Stream.

 

So what is the possible reason for this deterministic(it is seen all time ) error? 

 

Correct first 26 pixel in the first line : 

5180.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	64.0	68.0	72.0	76.0	80.0	84.0	88.0	92.0	96.0	100.0 ...

 

Received first 26 pixel in the first line: 

5180.0  0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0	0.0     64.0	68.0	72.0	76.0	80.0	84.0	88.0	92.0	96.0	100.0 ...

 

Why is there an extra 'zero' on the location of 17th pixel and why 1 pixel shift to right after the 17th pixel?

 

Waiting for reply,

Best Regards,

0 Kudos