UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
109 Views
Registered: ‎10-04-2018

1000BASE-KX link w/ Marvell 88E1512 not working on Zynq

Dear support,

We've a Zynq7000 in a custom board with the two ethernet interfaces connected via RGMII to both Marvell 88E1512 PHYs. They share MDIO bus connected to the first interface (Ethernet 0).

The eth0 interface goes to a 1000BASE-T interface and working fine and eth1 interface is connected via backplane to a VPX Ethernet Switch 1GBase-KX so we configure corresponding PHY to 1000BASE-X mode.

We've applied a patch for MDIO support as described in #AR69132 for Vivado 2018.3 which is our development version. We've also applied a patch to have visibility of both PHYs on uboot (0001_u-boot_multiple_phy_on_mdio.patch)

We're not able to get the link up for eth1.We tried many configurations for device tree looking into forum answers...we also tried to disable auto-negotiation in both ends without success. 

Can it be a kernel drivers issue? Or maybe a PHY misconfiguration? We're not sure about the next step to follow. Any advice would be really appreciated cause we've tried many configurations and variants with no success. 

I attach log files for uboot, linux kernel booting process, ifconfig and devicetree.

0 Kudos