cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
568 Views
Registered: ‎03-13-2018

gth transceivers wizard - powerdown not available using lab tools

Jump to solution

HI,

I am generating gth transceiver (costum settings) and want the option to power down the transceiver using lab tools (such as vio or by code).

I marked the txpowerdown and rxpowerdoen options so the ports will be at the top design (so I can change them).

I generated the example design.

in the example design top level  - GGG_exdes.v (assume IP name is GGG for example), there is a parameter called EXAMPLE_USE_CHIPESCOPE and its "1" as should be, but it doesnt transfer down to the other modules in this order (can see them as read only when I asked to expand the xci of the ip)

GGG_exdes.v ->  GGG.v -> GGG_support.v -> GGG_init.v

 

the power down is transfer for the top to the GGG.init.v file correctly, but in this file there is also a parameter called EXAMPLE_USE_CHIPESCOPE , BUT its sets to "0", which cause the code to ignore the power down signals from top level.

 

if the parameter would have passed through the module it would have worked because the top one would override the bottum one (parameter passing between modules ignore the default states).

or the default should have been "1"

since those files are inside the ip I can't change them.

 hoe to fix this problem so the EXAMPLE_USE_CHIPESCOPE in the GGG_init.v file will be set to "1" ?

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
566 Views
Registered: ‎08-07-2007

hi @asmatia

 

you can set the is_managed property to false, then you can edit the IP files. 

 

below is command line

set_property IS_MANAGED false [get_files <IP_NAME>.xci]

 

Please refer to UG896 page 108 and 109 for editing IP read-only files.

 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_2/ug896-vivado-ip.pdf

 

Thanks,

Boris

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------

View solution in original post

1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
567 Views
Registered: ‎08-07-2007

hi @asmatia

 

you can set the is_managed property to false, then you can edit the IP files. 

 

below is command line

set_property IS_MANAGED false [get_files <IP_NAME>.xci]

 

Please refer to UG896 page 108 and 109 for editing IP read-only files.

 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_2/ug896-vivado-ip.pdf

 

Thanks,

Boris

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------

View solution in original post