cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jcwill585
Adventurer
Adventurer
804 Views
Registered: ‎06-13-2019

zynq 7000 phy not detected when booting lwip echo server on standalone OS from SD Card on zturn board

Jump to solution

I changed the PHY driver to initialize the Microchip Gigabit ETH PHY, KSZ9031RNX.  The program boots fine when booted from JTAG and I get the message warning not a marvell phy and then goes on to get a link speed.  When booting from SD Card the zynq does not detect the PHY and does not autonegotiate.  Below is a screen shot.

image.png

0 Kudos
1 Solution

Accepted Solutions
jcwill585
Adventurer
Adventurer
676 Views
Registered: ‎06-13-2019

In order for the PHY to work when booting from SD card the MDIO and MDC pins must be enabled in the zynq configuration.  See screen shot below.

 

image.png

View solution in original post

0 Kudos
3 Replies
nanz
Moderator
Moderator
762 Views
Registered: ‎08-25-2009

HI @jcwill585 ,

Have you done the correct steps to initialize the PHY? Please check below AR:

https://www.xilinx.com/support/answers/63495.html

 


-------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs and our Versal Ethernet Sticky Note.

-------------------------------------------------------------------------------------------
0 Kudos
jcwill585
Adventurer
Adventurer
688 Views
Registered: ‎06-13-2019

Yes.  The same code works fine when I boot from JTAG.

0 Kudos
jcwill585
Adventurer
Adventurer
677 Views
Registered: ‎06-13-2019

In order for the PHY to work when booting from SD card the MDIO and MDC pins must be enabled in the zynq configuration.  See screen shot below.

 

image.png

View solution in original post

0 Kudos