UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer jdubb007
Observer
7,285 Views
Registered: ‎10-31-2011

ML507 ERR LED

Hello,
I'm working with an ML507 Development Board and I am having problems configuring the FPGA via the Compact Flash card. After I power-on the board, the ERR_LED remains on (red). I did some troubleshooting and noticed that the "INIT_B" LED is not on. The datasheet for the SYSACE Controller indicates that ERR_LED is asserted if an error occurs during configuration. In this case, the error is INIT_B not being asserted. Based on theML507's schematic it appears the Platform Flash (XCF32) drives INIT_B and will hold it low until the Vcco and Vccint voltages stabilize within 50 ms.

I performed the following during troubleshooting:
-Compared the jumper configurations against another ML507 that works properly.
-Successfully used the same Compact Flash Card on my working ML507 to configure the FPGA.
-Generated a bit file that contains a MicroBlaze with a "Hello World" stand-alone elf built into it. Programmed the FPGA via JTAG on both boards with this bit file and verified it runs correctly on both boards. 
-Used Impact to Erase both Platform Flashes and CPLD.

1.) Is it possible that Vcco and Vccint are not stabilizing within the 50ms window which causes the Platform Flash to hold INIT_B low? I would think if this were the case then configuration via JTAG would fail as well.

2.) Are there any other reasons why INIT_B would be held low?

Thanks

0 Kudos