UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer ru551n
Observer
10,144 Views
Registered: ‎02-09-2010

Problem programming the SP601 kit through USB

Jump to solution

Hello all!

 

I'm having trouble programming the SP601 kit through impact.

When I try to initalize the JTAG chain it just states:

"WARNING:iMPACT:923 - Can not find cable, check cable setup !"

 

I have tried the answers on this page as well: http://www.xilinx.com/support/answers/30184.htm

None of those worked for me.

 

I have tried installing both the 64 bit driver and the 32 bit driver. I am currently using windows 7 64 bit version.

 

I am currently in the process of reinstalling ISE 11.4 Webpack edition.

 

Anyone had the same problem?

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
12,991 Views
Registered: ‎01-03-2008

Re: Problem programming the SP601 kit through USB

Jump to solution

That is the correct connector.  The only thing that I can think of is that Windows 7 is not a supported OS for ISE 11.

 

There are reports of people that are using Windows 7, but there appears to also be a large number of issues reported as well.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
8 Replies
Xilinx Employee
Xilinx Employee
10,133 Views
Registered: ‎01-03-2008

Re: Problem programming the SP601 kit through USB

Jump to solution
Did you connect the USB cable to the correct USB port?
------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
Observer ru551n
Observer
10,131 Views
Registered: ‎02-09-2010

Re: Problem programming the SP601 kit through USB

Jump to solution

Yes, I believe so.

It is connected to the one marked "USB JTAG".

0 Kudos
Xilinx Employee
Xilinx Employee
12,992 Views
Registered: ‎01-03-2008

Re: Problem programming the SP601 kit through USB

Jump to solution

That is the correct connector.  The only thing that I can think of is that Windows 7 is not a supported OS for ISE 11.

 

There are reports of people that are using Windows 7, but there appears to also be a large number of issues reported as well.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
Observer ru551n
Observer
10,120 Views
Registered: ‎02-09-2010

Re: Problem programming the SP601 kit through USB

Jump to solution

Thank you for your reply.

I will try connecting the board to a computer with windows xp and see if that solves the problem.

 

I actually managed to program a bit file onto the board while using chipscope, I selected the bit file when initializing the program. Then the LED:s on the board lit up according to my test pattern.

 

When will there be full support for windows 7?

0 Kudos
Observer ru551n
Observer
10,049 Views
Registered: ‎02-09-2010

Re: Problem programming the SP601 kit through USB

Jump to solution

You were correct, the problem went away when I use windows xp (32-bit, SP3) instead.

Too bad there are compatibility issues with windows 7.

When are these going to be resolved?
 

0 Kudos
Xilinx Employee
Xilinx Employee
10,045 Views
Registered: ‎01-03-2008

Re: Problem programming the SP601 kit through USB

Jump to solution

There will be limited testing for Win7 in the upcoming ISE release, but it will not be officially supported.  The following ISE version is planned to have full support for Win7.

 

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
Visitor barmstrong
Visitor
9,623 Views
Registered: ‎04-28-2010

Re: Problem programming the SP601 kit through USB

Jump to solution

I had success by manually installing the driver on Windows 7 from the command line with the wdreg tool in the bin\nt64 directory of the installation files.

0 Kudos
Newbie mmmmec
Newbie
9,484 Views
Registered: ‎05-07-2010

Re: Problem programming the SP601 kit through USB

Jump to solution

Hi..

 

I am using a SPARTAN 3E cool runner 2 board...(Digilent) I am using Vista 64 Home Premium...

 

I see the same issue after installing the Xilinx 11.4 Webpack and also downloading the separate Programming tool package...

 

Is there any way I can overcome this ?

 

Changing to Windows XP or 32 bit is not an option ;-)

0 Kudos