UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor nakulkapoor1
Visitor
3,947 Views
Registered: ‎01-30-2012

Spartan 3A - ADC - unwanted amplification

Hi I am currently trying to sample a sine wave from a function generator using the ADC on the Spartan 3A and then output the data via the DAC to an oscilloscope. I have so far de-bugged my pre-amp and DAC settings and therefore am fairly confident that the problem is with my ADC settings.

 

Essentially the problem is that the data streaming from the ADC to the FPGA is amplified by a factor of around 2.6. This data I can effectively output onto the scope from the DAC.

 

I have set up a simulation that takes into account all the parallel to series and series to parallel conversion that the SPI would make and I have lined up the FPGA input clock edges from my simulation ADC to take in data when it is stable according to the user guide. I have taken into account the 2's complement issues by inverting the MSB out of the ADC before sending the data to the DAC and therefore offsetting the data into the desired range for the DAC.

 

I have attached picture of the simulation of just the ADC shift register at work and I think as it is it looks exactly as the user guide says it does. PLEASE correct me if I'm wrong.

 

I am basically now running out of ideas and am desperate for some guidance. I have looked on the forums and it seems like noone else really has had a problem like this. Any suggestions would be appreciated.

Thanks,

Nakul

sim-zoomADC.bmp
0 Kudos
2 Replies
Scholar joelby
Scholar
3,944 Views
Registered: ‎10-05-2010

Re: Spartan 3A - ADC - unwanted amplification

You probably mean the Spartan-3A Starter Kit, not the Spartan-3A itself (which doesn't have an ADC)

 

I'm not familiar with the parts on this board so your simulation doesn't mean anything to me, but here are some things to consider:

  • What are you setting the ADC amplifier gain to?
  • How are you determining the gain of 2.6? By comparing oscilloscope readings at the ADC input and DAC output? 
  • How are you converting the 14-bit result to a 12-bit programming word for the DAC?
  • Which DAC channel are you using, and what is its reference voltage set to?
  • Have you accounted for the ADC's VREF?
  • Have you compared your results to equations 9-1 and 10-1? Set a DC input voltage and read out the ADC word (using LEDs, LCD, spare I/Os, ChipScope, a serial console, or whatever) and see if the equations give the expected result.

 

0 Kudos
Visitor nakulkapoor1
Visitor
3,930 Views
Registered: ‎01-30-2012

Re: Spartan 3A - ADC - unwanted amplification

Hi thanks for your reply, I have sorted out my issues. I actually had misread the user guide!

Nakul

0 Kudos