UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor david_l
Visitor
696 Views
Registered: ‎06-06-2018

VCU118 FPGA is not recognized by vivado hw server

Hi everyone,

I've looked all over this message board, since this issue is quite common, yet every fix suggestion I encountered didn't solve the issue for me.

The problem is that upon connecting my VCU118 FPGA board to my PC (WIN7, using USB cable to the board JTAG port) and launching vivado's hw server, it doesn't recognize the board. I get the following error message:

 

[Labtoolstcl 44-27] No hardware targets exist on the server [localhost:3121]
Check to make sure the cable targets connected to this machine are properly connected
and powered up, then use the refresh_hw_server command to re-register the hardware targets.

 

I use vivado 2018.1not_working.PNGNot working...

(See attached image.)

I installed the cable drivers while the board is *Disconnected*

I have removed any FMC card, and didn't use a USB hub. Even re-install vivado didn't solve that.

One important thing to note:

I have another vcu118 board, which I am connecting to my PC, using the same cable and same SW, but this time, it does open that HW in vivado. I'm scratching my head here. (See image below.)

Lastly, the unrecognized board was fine a week ago, but some day vivado just stopped recognizing it.

Thank you guys

working.PNG

 

0 Kudos
9 Replies
Moderator
Moderator
660 Views
Registered: ‎02-09-2017

Re: VCU118 FPGA is not recognized by vivado hw server

Hi @david_l ,

 

Since you have already tested the same cable with a different board and it all worked, I assume the cable, drivers and the Vivado installation are all fine.

Would you have a different PC where you can try to connect to that board? That would help us isolate the issue to maybe being a board failure.

In addition, would be nice if you can also use a different cable and try to connect to that board, just for exhausting the possibilities (even better if instead of a Digilent cable you also have a Xilinx Platform Cable or a Smartlynq Cable).

Finally, the VCU118 has switches to configure the boot mode between JTAG and SPI. Could you please check those pins and make sure they are in JTAG mode (see more about this in the document VCU118 Board User Guide - UG1224 pg. 113).

It could also be that the  USB-to-JTAG configuration module stopped working. You could test that by using a Platform Cable and connecting directly to the JTAG header (connector J3).

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Moderator
Moderator
617 Views
Registered: ‎04-12-2017

Re: VCU118 FPGA is not recognized by vivado hw server

Hello @david_l 

Can you share with us the status of POwer Good LEDs on board ?

May I know if you have ran BIST on this board ? what were the results ?

also is it possible for you to try the platform cable to connect the board to vivado hardware manager ?

there can be two possible reasons for this failure:

1. Power issue

2. Failure of Digilent JTAG IC.

May i know if you observed this issue at time zero or after some usage of the board ?

Thank you

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Visitor david_l
Visitor
499 Views
Registered: ‎06-06-2018

Re: VCU118 FPGA is not recognized by vivado hw server

Hi, 

Thanks for replying. I put this thing aside for a while in favor of other urgent things.

Iv'e retunred to try and figure out this issue, as it happended again today with another board. 

See my comments inline.


@kvasantr wrote:

Hello @david_l 

Can you share with us the status of POwer Good LEDs on board ?

Sure, See pic: (I think they are OK)Untitled_led.png

 

May I know if you have ran BIST on this board ? what were the results ?

Yes, It's the first thing we've ran, and didn't see anything wrong. (with both boards)

also is it possible for you to try the platform cable to connect the board to vivado hardware manager ?

Yes, we have such cable + usb adaptor, and we were successful in connecting & programming the problematic VCU-118 FPGAs.

It seems like it's a faliure of the Diligent USB to JTAG IC.

there can be two possible reasons for this failure:

1. Power issue

2. Failure of Digilent JTAG IC.

May i know if you observed this issue at time zero or after some usage of the board ?

Thank you

 


I can provide some more details, we work on a WIN10 enviroment, with several other peripherals connected to USB ports, which uses FTDI chip in order to communicate with our workstations via USB. Both boards were functioning for a few days of usage, before the sudden connevtivity issue occuring.

Provided that it's really a problem with the Diligent JTAG IC, is there an option to "Factory reset" it? 

Thanks,

David.

0 Kudos
Visitor david_l
Visitor
440 Views
Registered: ‎06-06-2018

Re: VCU118 FPGA is not recognized by vivado hw server

Hi,

Can anyone please assist with this issue?

Does working with the platform cable provide a "smoking gun" for me to consult Digilent for their (probably) faulty component?

Thanks again,

David

0 Kudos
Xilinx Employee
Xilinx Employee
424 Views
Registered: ‎06-21-2018

Re: VCU118 FPGA is not recognized by vivado hw server

Hi David,

Have you tried connecting with a Platform Cable to the JTAG connector (like @anunesgu suggested) and that works?

That would be as close to a "smoking gun" for the Digilent module as I can think of...

Thanks,
Andres

 

0 Kudos
Highlighted
Advisor evgenis1
Advisor
417 Views
Registered: ‎12-03-2007

Re: VCU118 FPGA is not recognized by vivado hw server

Hi @david_l ,

One thing to try is to create target connection with much slower JTAG clock. It's probably something like 15MHz by default. Try to reduce it to 1MHz and see if there is any change. I do see similar issue from time to time, and this trick does help.

 

Thanks,

Evgeni

Tags (2)
Visitor david_l
Visitor
264 Views
Registered: ‎06-06-2018

Re: VCU118 FPGA is not recognized by vivado hw server

FYI,

Iv'e posted this question over at Digilent message board:

 

https://forum.digilentinc.com/topic/18310-xilinx-vcu-118-and-digilent-usb-2-jtag-ic-failure/

Thanks,

David.

0 Kudos
Visitor david_l
Visitor
219 Views
Registered: ‎06-06-2018

Re: VCU118 FPGA is not recognized by vivado hw server

Hi everyone,

The issue was solved by the Digilent technical support, they sent my a utility to re-flash the JTAG 2 USB IC.

Best regards,

David.

Xilinx Employee
Xilinx Employee
196 Views
Registered: ‎06-21-2018

Re: VCU118 FPGA is not recognized by vivado hw server

Hi David,

Thanks for the update! Please mark that answer as Accepted Solution, it might benefit other customers.

Cheers,
Andres

 

0 Kudos