UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor bear3316
Visitor
3,272 Views
Registered: ‎11-05-2008

xupv2p with 256M DDR, any limitation on calloc() with standalone OS?

Hi,

 

I am stuck by the calloc() function when porting a stream decoder application onto the xupv2p board.

 

The application works fine as a pure C software on VS2005 on my PC, while I've done everything ready (compiled, debug, hw/sw configuration, etc) to run it on the board. The calloc() function is not affected when doing the transporting.

 

the memory size I like to allocate would not exceed 3Mbytes, the system contains one ppc405, and all sections assigned to 256M DDR. I set the heap size to 128+64M but still doesn't work. Compilers, linkerScripts etc all follow the default. The OS is standalone.

 

I tried to change calloc() to malloc() + memset(0), no effect. I have another jpeg encoder using malloc() on smaller amount data, no problem. so just doubting if the malloc() or calloc() function comes with any limitation on the allocable size. Or the standalone OS gives any constraints on that?

  

I use EDK 10.1, xupv2p with 1 ppc405 and 256M DDR, plus one 512 CF.

 

 

Hope you encountered similiar problems before, and give any suggestion to help me out the trap.

 

 

Cheers, 

 

harry 

0 Kudos
1 Reply
Highlighted
Visitor 16189600
Visitor
2,188 Views
Registered: ‎08-06-2009

Re: xupv2p with 256M DDR, any limitation on calloc() with standalone OS?

Have you got an answer?
0 Kudos