cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
251 Views
Registered: ‎12-02-2019

JTAG Issue zynq z7020

I have set up a custom board with Zynq Z7020 SOC. I am not able to see either Either the FPGA or Arm cores in the Jtag debug software. The board is in Jtag boot mode.

  I'm using diligent HS3 cable and Using xsct software >connect >targets shows up error "DR shift output all zeros").

I have checked the voltage rails of both PS, PL, and PS_POR_B, power sequencing, clock and all seems to be working fine.

What else could be wrong?

0 Kudos
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
173 Views
Registered: ‎08-10-2008

回复: JTAG Issue zynq z7020

Check INIT_B, PROG_B  or DONE pin on the board, see if any of them is grounded.

------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
0 Kudos
Highlighted
165 Views
Registered: ‎12-02-2019

回复: JTAG Issue zynq z7020

Hey Iguo,

Thanks for your reply.

I have cross-checked the pins and they seem to be fine.

I am using the automative grade of the Zynq IC, will that require any special change compared to the commercial-grade connections?

Thanks

0 Kudos
Highlighted
135 Views
Registered: ‎12-02-2019

回复: JTAG Issue zynq z7020

Hey,

One more issue i noticed is that the Init_b pin, never goes low. (even in qspi flash and sd card boot mode, even if sd card is not present).

Ideally, it should go low when an error occurs right,

I have also attached part of  oscilloscope output (TDO vs TCK), TDO seems to be providing proper output for some part of TCK, but I am still getting the "DR shift output all zeros error).

jtag.png
0 Kudos