UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor cayla
Visitor
1,210 Views
Registered: ‎03-23-2009

Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hello,

 

Have a problem with my USB platform cable which sudently stopped working on my WIN10 PC (last week working without problem)

 

Connecting the probe to USB , no led STATUS LED light

 

gest_periph.jpg

I try to reinstall the driver manually, hereafter the log of install_drivers_wrapper.bat

 

Connecting the probe to another WIN10 PC and everythings working normally

 

Any idea about the problem or why windrv6 seems not installed ?

 

Thanks in advance for any help

 

------------------------------------------------------------------------------------------

 

INFO: InstallPath="C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\"
windrvr6 is not installed (this is expected for Windows 10 and later)
INFO: Installing Windows 10 pcusb driver...
Utilitaire Plug-and-Play Microsoft

Traitement du fichier inf :            xpcwinusb.inf
Package de pilotes correctement ajouté.
Nom publié :            oem45.inf


Tentatives totales :              1
Nombre d’importations réussies : 1

INFO: INF file C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win10\xpcwinusb.inf was successfully installed for driver.
INFO: Running digilent installer...

<<<<< Digilent Adept Runtime Setup >>>>>
Installer version: 1.4.6 release: 2015/12/08
Digilent Software Path: C:\Program Files (x86)\Digilent

Your system is up-to-date with the components of this installer.
INFO: Running SmartLynq installer...
INFO: SmartLynq installed successfully
INFO: InstallPath="C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\"
INFO: Uninstalling Windows 7 pcusb drivers...
WDREG utility v10.21. Build Aug 31 2010 14:21:54

Processing HWID USB\VID_03FD&PID_0008
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 0 devnodes
difx_uninstall_inf: err e0000302, last event 0, last error 0. ERROR_DRIVER_PACKAGE_NOT_IN_STORE
Warning: INF copy for C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win7\xusbdrvr.inf not found => not deleted.
Warning: the device (hwid:USB\VID_03FD&PID_0008) is not installed.

Processing HWID USB\VID_03FD&PID_0007
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 0 devnodes
Warning: the device (hwid:USB\VID_03FD&PID_0007) is not installed.

Processing HWID USB\VID_03FD&PID_0009
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 0 devnodes
Warning: the device (hwid:USB\VID_03FD&PID_0009) is not installed.

Processing HWID USB\VID_03FD&PID_000D
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 0 devnodes
Warning: the device (hwid:USB\VID_03FD&PID_000D) is not installed.

Processing HWID USB\VID_03FD&PID_000F
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 0 devnodes
Warning: the device (hwid:USB\VID_03FD&PID_000F) is not installed.

Processing HWID USB\VID_03FD&PID_0013
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 3 devnodes
Removed USB\VID_03FD&PID_0013\6&18A53BE6&0&1
Removed USB\VID_03FD&PID_0013\5&2108AD5D&0&1
Removed USB\VID_03FD&PID_0013\5&2108AD5D&0&12

Processing HWID USB\VID_03FD&PID_0015
Non-DIFxAPI uninstall, driver_in_store 0, devnode_exists 0, devnode_found 0
Uninstalled 0 devnodes
Warning: the device (hwid:USB\VID_03FD&PID_0015) is not installed.
uninstall: completed successfully
WDREG utility v10.21. Build Aug 31 2010 14:21:54

Processing HWID *WINDRVR6
LOG ok: 1, ENTER:  DriverPackageUninstallA
LOG ok: 1, ENTER:  DriverPackageUninstallW
LOG ok: 1, Uninstalling driver package C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win7\windrvr6.inf...
LOG ok: 1, Successfully uninstalled 'C:\WINDOWS\INF\oem80.inf'.
LOG ok: 0, Device with device instance ID 'ROOT\JUNGO\0000' reinstalled.
LOG ok: 1, Successfully uninstalled 1 devices for C:\WINDOWS\System32\DriverStore\FileRepository\windrvr6.inf_amd64_eddcd8eba6b279c1\windrvr6.inf.
LOG ok: 1, Successfully deleted properties for driver store entry 'C:\WINDOWS\System32\DriverStore\FileRepository\windrvr6.inf_amd64_eddcd8eba6b279c1\windrvr6.inf'.
LOG ok: 0, Uninstall completed.
LOG ok: 1, RETURN: DriverPackageUninstallW  (0x0)
LOG ok: 1, RETURN: DriverPackageUninstallA  (0x0)
difx_uninstall_inf: err 0, last event 0, last error 0. SUCCESS
uninstall: completed successfully
INFO: Installing Windows 10 pcusb driver...
Utilitaire Plug-and-Play Microsoft

Traitement du fichier inf :            xpcwinusb.inf
Package de pilotes correctement ajouté.
Nom publié :            oem45.inf


Tentatives totales :              1
Nombre d’importations réussies : 1

INFO: INF file C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win10\xpcwinusb.inf was successfully installed for driver.
INFO: Running digilent installer...

<<<<< Digilent Adept Runtime Setup >>>>>
Installer version: 1.4.6 release: 2015/12/08
Digilent Software Path: C:\Program Files (x86)\Digilent

Your system is up-to-date with the components of this installer.
INFO: Running SmartLynq installer...
INFO: SmartLynq installed successfully

 

 

 

 

 

0 Kudos
14 Replies
Xilinx Employee
Xilinx Employee
1,180 Views
Registered: ‎03-07-2018

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi @cayla

 

You can try following procedure for Platform cable USB II to work under Windows 10 environment:

1. Connect cable to PC/Laptop.

2. In device manager if cable is detected uninstall and delete driver of cable. 

3. Now after connecting cable, it should show unidentified device.

4. Remove platform USB cable

5. Navigate to "C:\Xilinx\14.7\ISE_DS\common\bin\nt64" for 64-bit installs or "C:\Xilinx\14.7\ISE_DS\common\bin\\nt" on 32-bit installs.(using Command Prompt in administrator mode)

6. Run wdreg -compat -inf %cd%\windrvr6.inf uninstall

7. Run wdreg -compat -inf %cd%\windrvr6.inf install

8. Connect the Xilinx USB cable.

 

Also take look at https://www.xilinx.com/support/answers/44397.html and https://www.xilinx.com/support/answers/54381.html

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Visitor cayla
Visitor
1,165 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Thanks for the procedure

 

Progress are : jungo Windriver appear now in the list but nothing new on "programming cable", "firmware loader" (see below)

 

When i connect the probe to another PC "programming cable" was "Xilinx usb cable" and it works as expected

 

gest_periph2.jpg

 

Regards

0 Kudos
Xilinx Employee
Xilinx Employee
1,158 Views
Registered: ‎03-07-2018

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi @cayla

 

After performing driver installation procedure provided in previous post.

Are you able to configure FPGA or not?

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Visitor cayla
Visitor
1,154 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Not on the faulty PC, i think maybe the problem is with the USB firmware downloading of the probe not working anymore ?

0 Kudos
Xilinx Employee
Xilinx Employee
1,152 Views
Registered: ‎03-07-2018

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi @cayla

 

If you have spare cable, give try on on your faulty PC.

Provide LED indication details after connecting cable to PC.

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Visitor cayla
Visitor
1,142 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

This is the same with a spare cable

 

Regards

0 Kudos
Visitor cayla
Visitor
1,141 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

No activity on LED

0 Kudos
Xilinx Employee
Xilinx Employee
1,123 Views
Registered: ‎03-07-2018

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi @cayla

 

I mean, which color is shown by platform cable LED after connecting to PC.

Provide us details of this PC (OS) on which platform cable worked correctly.

Did you tried changing USB ports?

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Visitor cayla
Visitor
1,120 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

HI

 

No color, the led doesn't light at all

 

The 2 PC OS are WIN10 professional 64 bits

 

yes i have tested diffrent USB ports

 

The cable was functionnal las week on the now faulty PC

 

Regards

0 Kudos
Xilinx Employee
Xilinx Employee
946 Views
Registered: ‎03-07-2018

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi @cayla

 

In this case you need to check host power is correct or not

Platform Cable USB II Data Sheet (DS593).png

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

 

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Visitor cayla
Visitor
939 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi

 

The host power is provided by USB bus and it's OK because the USB identify the probe as "programming cable" "Xilinx platform Cable USB II etc

 

I think it's realy a SW proble with the firmware download into the probe after USB identification

 

Normally the LED lights AMBER even the probe isn't connected target board (this the case on the working PC)

 

Regards

 

 

0 Kudos
Visitor cayla
Visitor
931 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi

 

Just trying to reinstall manually with WDREG ... with probe connected, it doesn't work well after that

 

 

C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win7>wdreg -inf xusbdrvr.inf install
WDREG utility v10.21. Build Aug 31 2010 14:21:54

Processing HWID USB\VID_03FD&PID_0008
Installing a signed driver package for USB\VID_03FD&PID_0008
Device node (hwid:USB\VID_03FD&PID_0008): does not exist and is not configured. Pre-installing.
LOG ok: 1, ENTER:  DriverPackagePreinstallA
LOG ok: 1, ENTER:  DriverPackagePreinstallW
LOG ok: 1, Driver package is already preinstalled 'C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win7\xusbdrvr.inf'.
LOG ok: 0, C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win7\xusbdrvr.inf is preinstalled.
LOG ok: 1, RETURN: DriverPackagePreinstallW  (0xB7)
LOG ok: 1, RETURN: DriverPackagePreinstallA  (0xB7)
 difx_install_preinstall_inf: err b7, last event 0, last error 0. ERROR_ALREADY_EXISTS

Processing HWID USB\VID_03FD&PID_0007
Installing a signed driver package for USB\VID_03FD&PID_0007
Device node (hwid:USB\VID_03FD&PID_0007): does not exist and is not configured. Pre-installing.

Processing HWID USB\VID_03FD&PID_0009
Installing a signed driver package for USB\VID_03FD&PID_0009
Device node (hwid:USB\VID_03FD&PID_0009): does not exist and is not configured. Pre-installing.

Processing HWID USB\VID_03FD&PID_000D
Installing a signed driver package for USB\VID_03FD&PID_000D
Device node (hwid:USB\VID_03FD&PID_000D): does not exist and is not configured. Pre-installing.

Processing HWID USB\VID_03FD&PID_000F
Installing a signed driver package for USB\VID_03FD&PID_000F
Device node (hwid:USB\VID_03FD&PID_000F): does not exist and is not configured. Pre-installing.

Processing HWID USB\VID_03FD&PID_0013
Installing a signed driver package for USB\VID_03FD&PID_0013
Device node (hwid:USB\VID_03FD&PID_0013): exists and is configured. Installing.
CM_Get_DevNode_Status ret value 0, status 1806400, problem 27
LOG ok: 1, ENTER:  DriverPackageInstallA
LOG ok: 1, ENTER:  DriverPackageInstallW
LOG ok: 1, Looking for Model Section [DeviceList.ntamd64]...
LOG ok: 1, Installing INF file 'C:\Xilinx\Vivado_Lab\2018.2\data\xicom\cable_drivers\nt64\dlc10_win7\xusbdrvr.inf' (Plug and Play).
LOG ok: 1, Looking for Model Section [DeviceList.ntamd64]...
LOG ok: 1, Installing devices with Id "USB\VID_03FD&PID_0013&REV_0000" using INF "C:\WINDOWS\System32\DriverStore\FileRepository\xusbdrvr.inf_amd64_1af2fe242bfdedb1\xusbdrvr.inf".
LOG ok: 1, Will force install because driver is not better and force flag is set.
LOG ok: 1, ENTER UpdateDriverForPlugAndPlayDevices...
LOG ok: 0, RETURN UpdateDriverForPlugAndPlayDevices.
LOG ok: 1, Installation was successful.
LOG ok: 1, Marked Phantom Device with Hardware/Compatible Id 'USB\VID_03FD&PID_0013&REV_0000' for reinstall on next plug-in.
LOG ok: 1, Marked Phantom Device with Hardware/Compatible Id 'USB\VID_03FD&PID_0013&REV_0000' for reinstall on next plug-in.
LOG ok: 0, Install completed
LOG ok: 1, RETURN: DriverPackageInstallW  (0x0)
LOG ok: 1, RETURN: DriverPackageInstallA  (0x0)
 difx_install_preinstall_inf: err 0, last event 0, last error 0. SUCCESS
install: completed successfully

 

 

0 Kudos
Xilinx Employee
Xilinx Employee
925 Views
Registered: ‎03-07-2018

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

Hi @cayla

 

Try following below steps:

 

Navigate to <Vivado Install Directory>\data\xicom\cable_drivers\nt64\\nt64 and run install_drivers_wrapper.bat

 

If above method does not work then, Perform all steps provided below for installing driver in Vivado:

  1. Make sure Platform Cable USB is unplugged
  2. Open a Windows cmd.exe prompt as Administrator
  3. In a command prompt browse to " <Vivado Install Directory>\data\xicom\cable_drivers\nt64\dlc10_win7" 
  4. To uninstall type the command: wdreg -compat -inf %cd%\windrvr6.inf uninstall
  5. To uninstall type the command:  wdreg -compat -inf %cd%\xusbdrvr.inf uninstall
  6. Run command: net stop XilinxPC4Driver
  7. Delete with command: %WINDIR%\system32\drivers\windrvr6.sys
  8. Delete with command: %WINDIR%\system32\drivers\xusb*.sys
  9. Delete with command: %WINDIR%\system32\drivers\xpc4drvr.sys
  10. To reinstall type the command: wdreg -compat -inf %cd%\windrvr6.inf install
  11. Plug in USB cable
  12. Go to Windows Device Manager. Look for 'Jungo'. Make sure it says 'WinDriver' under Jungo

If not, right-click and select 'Update Driver Software'.  Select 'Search automatically for updated driver software'

  1. Go back to CMD prompt (With plugged in USB cable)
  2. To reinstall type the command: wdreg -compat -inf %cd%\xusbdrvr.inf install
  3. Programmer status light should turn on and be green, if attached to target
  4. Run 'Cable Auto Connect' to verify

  

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

 

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Visitor cayla
Visitor
917 Views
Registered: ‎03-23-2009

Re: Platform Cable USB II Stopped Working : WIN 10 , windrv6 missing

hi

 

i follow your procedure line by line ... no success

 

 gest_periph3.jpg

 

Regards

0 Kudos