UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor pulkit.vlsi
Visitor
1,310 Views
Registered: ‎01-21-2012

Vivado 16 on Windows 10 64 bit DLC9 USB cable issue

Hi,

 

I have installed vivado 16 on windows 10 64 bit system.

Now i am trying to connect Xilinx USB cable DLC9G and it is showing error, "USB device is not recogniozed".

 

Please help.

 

Thanks in advance.

0 Kudos
4 Replies
Scholar dpaul24
Scholar
1,292 Views
Registered: ‎08-07-2014

Re: Vivado 16 on Windows 10 64 bit DLC9 USB cable issue

@pulkit.vlsi,

 

Which FPGA/Development Board are you using?

--------------------------------------------------------------------------------------------------------
FPGA enthusiast!
All PMs will be ignored
--------------------------------------------------------------------------------------------------------
0 Kudos
Xilinx Employee
Xilinx Employee
1,288 Views
Registered: ‎03-07-2018

Re: Vivado 16 on Windows 10 64 bit DLC9 USB cable issue

Hi @pulkit.vlsi

 

You can try following procedure for Platform cable USB II to work under Windows 10 environment:

1. Connect cable to PC/Laptop.

2. In device manager if cable is detected then uninstall and delete driver of cable. 

3. Now after connecting cable, it should show unidentified device.

4. Remove platform USB cable

5. Navigate to "C:\Xilinx\14.7\ISE_DS\common\bin\nt64" for 64-bit installs or "C:\Xilinx\14.7\ISE_DS\common\bin\\nt" on 32-bit installs.(using Command Prompt in administrator mode)

6. Run wdreg -compat -inf %cd%\windrvr6.inf uninstall

7. Run wdreg -compat -inf %cd%\windrvr6.inf install

8. Connect the Xilinx USB cable.

 

Also take look at https://www.xilinx.com/support/answers/44397.html and https://www.xilinx.com/support/answers/54381.html

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Teacher drjohnsmith
Teacher
1,277 Views
Registered: ‎07-09-2009

Re: Vivado 16 on Windows 10 64 bit DLC9 USB cable issue

@bpatil 

 

you mention the links to an ISE folder, 

 

the poster mentions vivado ? are you saying ISE and Vivado use the same ?

 

 

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
Xilinx Employee
Xilinx Employee
1,263 Views
Registered: ‎03-07-2018

Re: Vivado 16 on Windows 10 64 bit DLC9 USB cable issue

Hi @drjohnsmith and @pulkit.vlsi

 

Oh!!!

 

Navigate to <Vivado Install Directory>\data\xicom\cable_drivers\nt64\\nt64 and run install_drivers_wrapper.bat

 

If above method does not work then, Perform all steps provided below for installing driver in Vivado:

  1. Make sure Platform Cable USB is unplugged
  2. Open a Windows cmd.exe prompt as Administrator
  3. In a command prompt browse to " <Vivado Install Directory>\data\xicom\cable_drivers\nt64\dlc10_win7" 
  4. To uninstall type the command: wdreg -compat -inf %cd%\windrvr6.inf uninstall
  5. To uninstall type the command:  wdreg -compat -inf %cd%\xusbdrvr.inf uninstall
  6. Run command: net stop XilinxPC4Driver
  7. Delete with command: %WINDIR%\system32\drivers\windrvr6.sys
  8. Delete with command: %WINDIR%\system32\drivers\xusb*.sys
  9. Delete with command: %WINDIR%\system32\drivers\xpc4drvr.sys
  10. To reinstall type the command: wdreg -compat -inf %cd%\windrvr6.inf install
  11. Plug in USB cable
  12. Go to Windows Device Manager. Look for 'Jungo'. Make sure it says 'WinDriver' under Jungo

If not, right-click and select 'Update Driver Software'.  Select 'Search automatically for updated driver software'

  1. Go back to CMD prompt (With plugged in USB cable)
  2. To reinstall type the command: wdreg -compat -inf %cd%\xusbdrvr.inf install
  3. Programmer status light should turn on and be green, if attached to target
  4. Run 'Cable Auto Connect' to verify

 

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------