UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
7,979 Views
Registered: ‎03-14-2012

An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

Hi, I am very confused and need some help.

 

There is an error when I creat a porject with exapple design xapp739. The error is as follow:

 

ERROR:HDLCompiler:1654 - "E:\AXI_PROJECT\new_xapp739\projnav\ipcore_dir\vdma_synth.v" Line 252: Instantiating <inst> from unknown module <axi_vdma>

 

My ISE version is 13.4, The axi_vdma ipcore version is 5.00.a.

 

I have creat an instantion about axi_vdma using CORE Generator, Why have the mistake?

 

Thanks.

Tags (1)
0 Kudos
9 Replies
Xilinx Employee
Xilinx Employee
7,970 Views
Registered: ‎08-02-2011

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

Please stop cross-posting this same thread to many forums. One post is enough. Take the time to make sure it ends up in the correct place, and the right people will help you answer it.

 

Have you tried cleaning the project and re-generating the core?

 

Is this a verilog design or VHDL? I seem to recall a known issue with one of the combinations of core version/ISE version where a verilog instantiation of the VDMA resulted in incorrect .prj being generated. In which case, you can black box the core and bring it into your project as an NGC or use a newer version of the core and/or software.

www.xilinx.com
0 Kudos
Adventurer
Adventurer
7,962 Views
Registered: ‎03-14-2012

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

Of cause, I have regenerate all ipcores. Also I have trid manys ISE version, ISE13.2, 13.4, 14.1, 14.2.

 

But only in ISE 14.2, there is no this mistake.

 

Thanks.

0 Kudos
Adventurer
Adventurer
7,950 Views
Registered: ‎03-14-2012

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

Additionally, the IPcore AXI_datamover has the same problem.

 

Now, even if i instiantiate these ipcores in ISE14.2, including axi_vdma and axi_datamover, there is the same problem when I want to simulate these ipcores.

 

I am very confused.

 

Thanks. I am look forward to your post.

0 Kudos
Xilinx Employee
Xilinx Employee
7,944 Views
Registered: ‎08-02-2011

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

I have not tried the datamover, but I know for certain that v5.02.a of the AXI VDMA synthesizes in 14.2 without issue.

 

When testing different versions of ISE on the same project, make sure you clean the project and allow the cores and prj files to be re-generated.

www.xilinx.com
0 Kudos
Adventurer
Adventurer
7,930 Views
Registered: ‎03-14-2012

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

I also have verified correctness in ISE14.2, but why is not right in other ISE version?

 

 

 

0 Kudos
Xilinx Employee
Xilinx Employee
7,914 Views
Registered: ‎08-02-2011

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

It's a known issue. As mentioned, the tools weren't generating the correct .prj files in certain cases so it wouldn't grab all the necessary source code to compile the core.

www.xilinx.com
0 Kudos
Contributor
Contributor
3,207 Views
Registered: ‎10-17-2014

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

Hi @bwiec,

 

i am facing this issue as well in ISE 14.7. The axi vdma core is of version 5.04a. Do you have any solution or workaroud for this issue?  

 

Attached is the fuse.log for your references. 

 

Kindly do advice and any help will be deely appreciates. 

 

Many Thanks.

0 Kudos
Xilinx Employee
Xilinx Employee
3,203 Views
Registered: ‎07-31-2012

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

@aaron0530 please create a new post for this with the full details. Firstly please try the above suggestions to re-generate the cores and try. Include the test case if possible along with the new post.
Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos
Contributor
Contributor
3,199 Views
Registered: ‎10-17-2014

Re: An error about AXI VDMA with example design xapp739 : Instantiating <inst> from unknown module <axi_vdma>

Hi @athandr,

 

thanks for your reply. i have created a new post and the link is:

 

https://forums.xilinx.com/t5/Simulation-and-Verification/Unable-to-simulate-AXI-VDAM-v5-04a/m-p/660461/highlight/false#M14444

 

Kindly do advice on how can i workaround this error. 

 

Thanks

Aaron

0 Kudos