UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
5,541 Views
Registered: ‎08-23-2011

setting and resetting the XIL_TIMING_ALLOW_IMPOSSIBLE

hi,

 

i have xilinx ISE 10.1 on windows XP.

 

i had some timing issues in map so I set the xil_timing_allow_impossible to 1 in the tcl window in ISE.

 

the map went through.

 

however, now when I reset the xil_timing_allow_impossible back to 0, map is still completing successfully, even though I can see some timing violations in the post map timing report.

 

the syntax I used to set the  env variable is -

% set env(XIL_TIMING_ALLOW_IMPOSSIBLE) 1

1

% echo $env(XIL_TIMING_ALLOW_IMPOSSIBLE)

1

 

the syntax I used to reset the env variable is -

% set env(XIL_TIMING_ALLOW_IMPOSSIBLE) 0

0

% echo $env(XIL_TIMING_ALLOW_IMPOSSIBLE)
0

 

So am I even setting/resetting this env. variable properly? or am I missing something in the syntax?

 

And if I am resetting the variable properly, how come map goes through next time around, even when there are timing violations.

 

Help!

 

z.

 

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
5,535 Views
Registered: ‎07-01-2010

Re: setting and resetting the XIL_TIMING_ALLOW_IMPOSSIBLE

Hi,

Once after modifying the variable have you closed the ISE and relaunch ?
Please try to re-launch the tool and the variable is modified.

Regards,
Achutha
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
5,531 Views
Registered: ‎08-23-2011

Re: setting and resetting the XIL_TIMING_ALLOW_IMPOSSIBLE

i did relaunch ISE, however, after launching it again, when i do -

 

echo $env(XIL_TIMING_ALLOW_IMPOSSIBLE)

 

i get the error message -

can't read "env(XIL_TIMING_ALLOW_IMPOSSIBLE)": no such variable

 

do i need to reset this env variable after relaunching and then echo it?

 

i would assume since its a xilinx env variable, it should show the prev. value that was set ... 

 

 

0 Kudos
Teacher muzaffer
Teacher
5,514 Views
Registered: ‎03-31-2012

Re: setting and resetting the XIL_TIMING_ALLOW_IMPOSSIBLE

I think the tools are checking whether the environment variable is defined at all and not the value of it. So removing the variable is the right thing to do instead of setting it to zero. Did you try running through the flow again after removing it?
- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Explorer
Explorer
5,508 Views
Registered: ‎08-23-2011

Re: setting and resetting the XIL_TIMING_ALLOW_IMPOSSIBLE

ive done the following (in sequence) -

 

-set the xil_timing_allow_impossible to 0

-shut down all the ISE instances i might have open

-shut down the computer

-restart the computer, open the project again

-cleanup project 

-run the map again ... BUT map is still succeeding, even though in the post map timing report, there are failures and errors!

 

echo of xil_timing_allow_impossible again says - variable not present.

 

how else can i reset this variable???????????????? 

 

please help!! :( :(

0 Kudos