UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Teacher xilinxacct
Teacher
636 Views
Registered: ‎10-23-2018

Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL 000 to DSP48E1 instance is invalid.

Jump to solution

Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL  000 to DSP48E1 instance is invalid.

This warning has been reported again multiple versions 2016.1, 2016.2, 2016.4 , 2017.2 .... It appears to still exist in 2018.3

https://forums.xilinx.com/t5/Simulation-and-Verification/Warning-OPMODE-Input-Warning-The-OPMODE-0110X0X-with-CARRYINSEL/td-p/702538

In the above link, it appears noone really knows why, but the conclusion was it can be ignored.

1) Can it really be ignored?

2) Should this warning really be emitted or is the warning itself something that should be fixed. (i.e. if the user can't do anything about it, it seems 'informational' at best)

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
573 Views
Registered: ‎06-24-2015

Re: Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL 000 to DSP48E1 instance is invalid.

Jump to solution

@xilinxacct 

 

You can change the "cosim_design" in script.tcl to "cosim_design -disable_depchk" to skip this check.

Yes, these can be safely ignored.

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
4 Replies
Moderator
Moderator
574 Views
Registered: ‎06-24-2015

Re: Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL 000 to DSP48E1 instance is invalid.

Jump to solution

@xilinxacct 

 

You can change the "cosim_design" in script.tcl to "cosim_design -disable_depchk" to skip this check.

Yes, these can be safely ignored.

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
486 Views
Registered: ‎10-02-2018

Re: Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL 000 to DSP48E1 instance is invalid.

Jump to solution

I apologize for necro'ing thisthread, but I have tried to use this solution to no avail, as either Vivado HLS deletes the option from the script.tcl or the Vivado HLS Command Prompt doesn't recognize the option. Furthermore, this is the only instance on the internet of this potential solution.

 

Any advice?

0 Kudos
Moderator
Moderator
455 Views
Registered: ‎06-24-2015

Re: Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL 000 to DSP48E1 instance is invalid.

Jump to solution

@miguel.cardoso 

You can use this switch starting from 2019.1.

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
0 Kudos
Explorer
Explorer
312 Views
Registered: ‎08-31-2017

Re: Warning: OPMODE Input Warning : The OPMODE 0110X0X with CARRYINSEL 000 to DSP48E1 instance is invalid.

Jump to solution

@nupurs 

Nice to hear about the 2019.1 version has some work around solution to the daunting problem.

However, I have a question about the usage. As you mentioned, user should open the cosim.tcl to modify and then rerun the tcl. Is it that case ?

Does the C/RTL cosim support such disable option in the GUI ?

Thanks

0 Kudos