UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer taoluwork
Observer
865 Views
Registered: ‎09-17-2018

drivers not generated in impl folder

Jump to solution

Hi experts,

I had an issue that the "drivers" folder not generated in my impl folder. So that I cannot find my "xModule.h" file in my SDK design. My project is targeted at board zc706 with zynq-7 on it. What is the possible reason for this? I've been run synthesis and export many times but not solve this. I guess it could be the settings but cannot locate this in the tutorial.

Please help!

Thanks!

Taurus

0 Kudos
1 Solution

Accepted Solutions
Adventurer
Adventurer
796 Views
Registered: ‎07-20-2017

Re: drivers not generated in impl folder

Jump to solution

@taoluwork

Is your IP streaming or AXI slave? If you have implemented your HLS IP as streaming then it will not require driver so driver folder is not generated. 

Regards, abhidan@logictronix.com
Please mark the Answer as "Accept as solution" if information provided solves your query. Give Kudos if you think it was helpful and reply oriented.

View solution in original post

4 Replies
Observer taoluwork
Observer
863 Views
Registered: ‎09-17-2018

Re: drivers not generated in impl folder

Jump to solution

Quick correction: the drivers folder should be under solution1/impl/ip/drivers.

I can see that in some example project but my design did not generate it.

0 Kudos
Observer taoluwork
Observer
848 Views
Registered: ‎09-17-2018

Re: drivers not generated in impl folder

Jump to solution

Update: I can successfully generate the drivers folder on a very simple design using default settings. Thus the tool chain / setting has no issue. However, I cannot generate that even I recreate a project, still.

 

Question: I've followed the tutorial to use module in SDK by including the xModule.h file in the drivers folder. If that folder is not necessarily generated, how could I use my module in SDK or in vivado system design?

0 Kudos
Adventurer
Adventurer
797 Views
Registered: ‎07-20-2017

Re: drivers not generated in impl folder

Jump to solution

@taoluwork

Is your IP streaming or AXI slave? If you have implemented your HLS IP as streaming then it will not require driver so driver folder is not generated. 

Regards, abhidan@logictronix.com
Please mark the Answer as "Accept as solution" if information provided solves your query. Give Kudos if you think it was helpful and reply oriented.

View solution in original post

Observer taoluwork
Observer
784 Views
Registered: ‎09-17-2018

Re: drivers not generated in impl folder

Jump to solution

Hi, thank you for your reply. I think you are right. That driver is not generated necessarily. I did not set my IP interface, but I can read result from memory directly. Thanks!

0 Kudos