UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Voyager
Voyager
7,269 Views
Registered: ‎04-10-2012

Any way to disable Aurora to allow MAP to finish?

I am working on a design that someone else had previously instantiated Aurora into.  I was doign some advancements that used too many resources, so I decided to put some paramaters around the aurora stuff to allow me to test without instantiating it, but not change the code.  That seems to throw things for a loop.

 

What I think the issue is, is that the aurora clock input/output pins are on particular  pins, and the tools are expecting something of them.  I was able to get through most of the issues by adding the following statements (just to make the tools happy):

wire GTXQ1_CLK;		
IBUFDS_GTXE1 IBUFDS_GTXE1_CLK1
(
  .I      (GTX_CLK_P2),
  .IB     (GTX_CLK_N2),
  .CEB    (1'b0),
  .O      (GTXQ1_CLK),
  .ODIV2  ()
);
			
wire RXin1;
wire RXin2;
IBUFGDS IBUFGDS1 (
 .I(SFP1_RXP),
 .IB(SFP1_RXN),
 .O(RXin1)	 
);  

IBUFGDS IBUFGD2 (
 .I(SFP2_RXP),
 .IB(SFP2_RXN),
 .O(RXin2)	 
); 

 Everything is good except that the output pins are now failing MAP (SFP1_TXP, SFP1_TXN, SFP2_TXP, and SFP2_TXN).  Is there anything I can do to those pins to make the tools happy?

 

The error I get looks like this:

Pack:1107 - Pack was unable to combine the symbols listed below into a single IOBS component because the site type selected is not compatible. 
Further explanation:
The component type is determined by the types of logic and the properties and configuration of the logic it contains. In this case an IO component of type IOBS was chosen because the IO contains symbols and/or properties consistent with differential slave usage. Please double check that the types of logic elements and all of their relevant properties and configuration options are compatible with the physical site type of the constraint.
Summary:
Symbols involved:
	PAD symbol "SFP1_TXN" (Pad Signal = SFP1_TXN)
	SlaveBuffer symbol "OBUFDS1/SLAVEBUF.DIFFOUT" (Output Signal = SFP1_TXN)
Component type involved: IOBS
Site Location involved: Y2
Site Type involved: OPAD

 

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
7,260 Views
Registered: ‎01-03-2008

Re: Any way to disable Aurora to allow MAP to finish?

I think that you have removed the Aurora core and are attempting to replace with an IBUFDS for the RXP/RXN and an OBUFDS for the TXP/TXN.  You cannot do this as the only valid connection the dedicated MGT pins is the MGT.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
Xilinx Employee
Xilinx Employee
7,253 Views
Registered: ‎07-01-2008

Re: Any way to disable Aurora to allow MAP to finish?

Pack needs the context of the GT connectivity to create the correct component type of OPAD instead of an IOB. The error occurs because an IOB is a mismatch for the OPAD site.

0 Kudos
Voyager
Voyager
7,232 Views
Registered: ‎04-10-2012

Re: Any way to disable Aurora to allow MAP to finish?

I have removed the core (basically put it in a parameter check that never resolves), and just wanted to tools to run.  It complained about the TXP/TXN, so I did indeed toss some OBUFDS in there to try to make the tools happy (which obviously didn't work).  

 

Is there something I can do to make the tools have (re the TXP/TXN pins) without the core being there (maybe something the equivelent of the IBUFDS_GTXE1)? (or maybe a way to wrap the output pins in the ucf in the parameter check)?

0 Kudos
Xilinx Employee
Xilinx Employee
7,222 Views
Registered: ‎01-03-2008

Re: Any way to disable Aurora to allow MAP to finish?

I think that the only way to resolve this is to remove the ports from the top level design and comment out the UCF.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos