UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
12,205 Views
Registered: ‎03-26-2010

Par: 491 - Multi-threading for Partitions Disabled

Hi all,

 

Running PAR on a Spartan-6 design with partitions - got this message:


Par: 491 - Multi-threading ("-mt" option) is not supported for the Partition based flow. PAR will use only one processor.

 

Previously, MAP reported that it worked with multithreading just fine. I've got a powerful box with 6 processors for this.... Shame not to use it. Does anyone at Xilinx know when PAR multi-threading support will be enabled for partition based flows?

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
12,163 Views
Registered: ‎06-11-2009

Re: Par: 491 - Multi-threading for Partitions Disabled

You can enable muti-threading option in 12.2 in ISE and Planahead for S-6 DEVICE

Try using the -mt switch. Can you please specfiy your ISE or Planahead version?

See the attched screenshot

mt.JPG
Explorer
Explorer
12,156 Views
Registered: ‎03-26-2010

Re: Par: 491 - Multi-threading for Partitions Disabled

I'm using ISE/PlanAhead 12.2 with a partitioned-based flow... As I said, the -mt switch is used for both MAP and PAR, but I get a warning that it's not supported for PAR in the case of partitions, only multithreaded MAP is allowed. Attached is the screenshot of my implementation settings in PlanAhead. Is that really the case, and if so, when will this be changed?

PlanAhead_Settings.jpg
0 Kudos
Highlighted
11,612 Views
Registered: ‎03-31-2012

Re: Par: 491 - Multi-threading for Partitions Disabled

how to solve the problem

Tags (1)
0 Kudos
Xilinx Employee
Xilinx Employee
11,591 Views
Registered: ‎02-11-2010

Re: Par: 491 - Multi-threading for Partitions Disabled

Note in the Command Line Tools User Guide states as follows:

Note This option is available for Spartan®-6, Virtex®-6, and Virtex-5 devices only.
Multithreading is not available when you are using -smartguide, -power on, -x,
partitions, or a project without a PCF file.

 

It is clearly shown that mutli-threading is not available when using partitions

0 Kudos