cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
9,252 Views
Registered: ‎10-01-2015

Place 30-4 Error

Jump to solution

Hello,

 

I'm running into the follwoing error and I can't find any documentation to solve the probelm.  My design is targeted at a Zynq7020 and the placer fails to even attempt to fit the design.  Here is the exact error:

 

[Place 30-4] Design utilization is very high. Run report_utilization command to see design utilization. Abandoning placement as chances are very low that placement is possible. To skip this check run placement with 'place.skipUtilizationCheck' parameter set.

 

Anyone know where this is documented, or how to fix it?

 

Thanks in advance.

Adam

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
17,330 Views
Registered: ‎09-20-2012

Hi @snikrepmada-athena

 

You can try the parameter suggested in the error message

 

set_param place.skipUtilizationCheck 1

 

Run the above command in Vivado TCL console and rerun Implementation.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)

View solution in original post

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
9,245 Views
Registered: ‎09-20-2012

Hi @snikrepmada-athena

 

Open synthesized design and run report_utilization command from TCL console.

 

Check if there are any resources which are highly utilized. Attach the log here if possible.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Highlighted
9,223 Views
Registered: ‎10-01-2015

Hello @vemulad,

 

Thank for the quick reply.  My utilization of resources is semi-high, the flip-flops are at 79% and the LUTs are at 61%.  I know the design will fit but, I can't figure out how to override the utilization check there does not seem to be an entry to ignore that check in the implementation settings and I cna't find a reference to it in the TCL documentation.

 

Respectfully,

Adam

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
17,331 Views
Registered: ‎09-20-2012

Hi @snikrepmada-athena

 

You can try the parameter suggested in the error message

 

set_param place.skipUtilizationCheck 1

 

Run the above command in Vivado TCL console and rerun Implementation.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)

View solution in original post

0 Kudos
Highlighted
9,202 Views
Registered: ‎10-01-2015

@vemulad

 

Thank you very much for your help.

0 Kudos