UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor xlmeng
Visitor
502 Views
Registered: ‎06-21-2018

Floating license error: UNSUPPORTED: vlm_check (PORT_AT_HOST_PLUS )

Jump to solution

 

I have installed "License Manager Tool - 1018.2 Utilities" on my Linux server:

Floating Server Tools Linux (Flex v11.14.1.0) (ZIP - 20.37 MB)

MD5 SUM Value : c6b80cf968b2a5721f684f8190ce1e93

and start  it on a non-root user, server ip is 192.168.1.12, use default port 2100:

./linux_flexlm_v11.14.1.0/lnx64.o/lmgrd.sh -c /home/installer/Xilinx_lic/Xilinx.lic -l /home/installer/Xilinx_lic/Xilinx_lic.log

 The log file:

15:26:47 (lmgrd) -----------------------------------------------
15:26:47 (lmgrd)   Please Note:
15:26:47 (lmgrd) 
15:26:47 (lmgrd)   This log is intended for debug purposes only.
15:26:47 (lmgrd)   In order to capture accurate license
15:26:47 (lmgrd)   usage data into an organized repository,
15:26:47 (lmgrd)   please enable report logging. Use Flexera Software LLC's
15:26:47 (lmgrd)   software license administration  solution,
15:26:47 (lmgrd)   FlexNet Manager, to  readily gain visibility
15:26:47 (lmgrd)   into license usage data and to create
15:26:47 (lmgrd)   insightful reports on critical information like
15:26:47 (lmgrd)   license availability and usage. FlexNet Manager
15:26:47 (lmgrd)   can be fully automated to run these reports on
15:26:47 (lmgrd)   schedule and can be used to track license
15:26:47 (lmgrd)   servers and usage across a heterogeneous
15:26:47 (lmgrd)   network of servers including Windows NT, Linux
15:26:47 (lmgrd)   and UNIX.
15:26:47 (lmgrd) 
15:26:47 (lmgrd) -----------------------------------------------
15:26:47 (lmgrd) 
15:26:47 (lmgrd) 
15:26:47 (lmgrd) Server's System Date and Time: Tue Nov 27 2018 15:26:47 CST
15:26:47 (lmgrd) SLOG: Summary LOG statistics is enabled.
15:26:47 (lmgrd) FlexNet Licensing (v11.14.1.0 build 194335 x64_lsb) started on asia.deepoly.com (linux) (11/27/2018)
15:26:47 (lmgrd) Copyright (c) 1988-2016 Flexera Software LLC. All Rights Reserved.
15:26:47 (lmgrd) World Wide Web:  http://www.flexerasoftware.com
15:26:47 (lmgrd) License file(s): /home/installer/Xilinx_lic/Xilinx.lic
15:26:47 (lmgrd) lmgrd tcp-port 2100
15:26:47 (lmgrd) (@lmgrd-SLOG@) ===============================================
15:26:47 (lmgrd) (@lmgrd-SLOG@) === LMGRD ===
15:26:47 (lmgrd) (@lmgrd-SLOG@) Start-Date: Tue Nov 27 2018 15:26:47 CST
15:26:47 (lmgrd) (@lmgrd-SLOG@) PID: 62312
15:26:47 (lmgrd) (@lmgrd-SLOG@) LMGRD Version: v11.14.1.0 build 194335 x64_lsb ( build 194335 (ipv6))
15:26:47 (lmgrd) (@lmgrd-SLOG@) 
15:26:47 (lmgrd) (@lmgrd-SLOG@) === Network Info ===
15:26:47 (lmgrd) (@lmgrd-SLOG@) Listening port: 2100
15:26:47 (lmgrd) (@lmgrd-SLOG@) 
15:26:47 (lmgrd) (@lmgrd-SLOG@) === Startup Info ===
15:26:47 (lmgrd) (@lmgrd-SLOG@) Server Configuration: Single Server
15:26:47 (lmgrd) (@lmgrd-SLOG@) Command-line options used at LS startup: -c /home/installer/Xilinx_lic/Xilinx.lic -l /home/installer/Xilinx_lic/Xilinx_lic.log 
15:26:47 (lmgrd) (@lmgrd-SLOG@) License file(s) used:  /home/installer/Xilinx_lic/Xilinx.lic
15:26:47 (lmgrd) (@lmgrd-SLOG@) ===============================================
15:26:47 (lmgrd) Starting vendor daemons ... 
15:26:47 (lmgrd) Started xilinxd (internet tcp_port 44334 pid 62313)
15:26:47 (xilinxd) Unable to initialize access to trusted storage: 2
15:26:47 (xilinxd) FlexNet Licensing version v11.11.0.0 build 106800 x64_lsb
15:26:47 (xilinxd) lmgrd version 11.14, xilinxd version 11.11

15:26:48 (xilinxd) Server started on asia.deepoly.com for:	
15:26:48 (xilinxd) SDAccel (consisting of:		Simulation	
15:26:48 (xilinxd) Analyzer	PartialReconfiguration Implementation	
15:26:48 (xilinxd) HLS		Synthesis	ap_opencl)	
15:26:48 (xilinxd) PetaLinux_NoSuport_Eval (consisting of:		petalinux_arch_microblaze 
15:26:48 (xilinxd) petalinux_arch_ppc petalinux_arch_zynq) 
15:26:48 (xilinxd) SDSoC_Tools (consisting of:		ap_sdsoc	
15:26:48 (xilinxd) ap_cc		SDK		XC7Z010		
15:26:48 (xilinxd) XC7Z030		XC7Z045		Simulation	
15:26:48 (xilinxd) Analyzer	XC7Z020		XC7Z100		
15:26:48 (xilinxd) xc7z015		xc7z035)		ap_sdsoc	
15:26:48 (xilinxd) ap_cc		v_cresample	v_cresample	
15:26:48 (xilinxd) v_osd		v_osd		v_osd_v1_0	
15:26:48 (xilinxd) v_rgb2ycrcd	v_rgb2ycrcb	v_rgb2ycrcb_v2	
15:26:48 (xilinxd) v_rgb2ycrcb_v2	v_tc		v_tc		
15:26:48 (xilinxd) v_tpg		v_tpg		v_ycrcb2rgb_v2	
15:26:48 (xilinxd) v_ycrcb2rgb_v2	v_ycrcb2rgb	v_ycrcb2rgb	
15:26:48 (xilinxd) XCZU9EG-ES1_bitgen xczu9eg-es1	XCZU9EG-ES2_bitgen 
15:26:48 (xilinxd) XCZU3EG-ES1_bitgen xczu3eg-es1	XCZU15EG-ES1_bitgen 
15:26:48 (xilinxd) XCZU15EG-ES1	XCZU19EG-ES2_bitgen XCZU19EG-ES2	
15:26:48 (xilinxd) XCZU9EG-ES2	v_proc_ss	v_proc_ss	
15:26:48 (xilinxd) v_mix		v_mix		mipi_csi2_rx_ctrl 
15:26:48 (xilinxd) mipi_csi2_rx_ctrl v_hdmi		v_hdmi		
15:26:48 (xilinxd) XCZU9EG		xazu2eg_bitgen	XCZU2EG-EVAL	
15:26:48 (xilinxd) XCZU4EV-EVAL	xczu4ev		xczu5ev		
15:26:48 (xilinxd) XCZU5EV-EVAL	xczu7ev		xczu7ev_bitgen	
15:26:48 (xilinxd) XCZU11EG-EVAL	xczu2cg		xczu2cg_bitgen	
15:26:48 (xilinxd) xczu3cg		xczu3cg_bitgen	xczu4ev_bitgen	
15:26:48 (xilinxd) xczu2eg		xczu2eg_bitgen	xczu3eg		
15:26:48 (xilinxd) xczu3eg_bitgen	xczu4eg		xczu4eg_bitgen	
15:26:48 (xilinxd) xczu4cg		xczu4cg_bitgen	xczu5eg		
15:26:48 (xilinxd) xczu5eg_bitgen	xczu5cg		xczu5cg_bitgen	
15:26:48 (xilinxd) xczu7eg		xczu7eg_bitgen	xczu7cg		
15:26:48 (xilinxd) xczu7cg_bitgen	XCZU6EG-EVAL	xczu6eg		
15:26:48 (xilinxd) xczu6eg_bitgen	xczu6cg		xczu6cg_bitgen	
15:26:48 (xilinxd) xczu9cg		xczu9cg_bitgen	xczu11eg	
15:26:48 (xilinxd) xczu15eg	XCZU17EG-EVAL	xczu17eg	
15:26:48 (xilinxd) XCZU19EG	ModelComposer	
15:26:48 (xilinxd) EXTERNAL FILTERS are OFF
15:26:48 (lmgrd) xilinxd using TCP-port 44334

 

Then I start SDx 2018.2 after setting the following enviorment: (Please refer to the attachment for this process.)

export XILINXD_LICENSE_FILE="2100@192.168.1.12"
export LM_LICENSE_FILE="2100@192.168.1.12"

The tail of log file is:

15:26:48 (xilinxd) EXTERNAL FILTERS are OFF
15:26:48 (lmgrd) xilinxd using TCP-port 44334
15:36:23 (xilinxd) TCP_NODELAY NOT enabled
15:36:23 (xilinxd) OUT: "SDAccel" xlmeng@oceania  
15:36:23 (xilinxd) OUT: "ap_opencl" xlmeng@oceania  
15:36:23 (xilinxd) IN: "SDAccel" xlmeng@oceania  
15:36:23 (xilinxd) IN: "ap_opencl" xlmeng@oceania  
15:36:23 (xilinxd) OUT: "SDAccel" xlmeng@oceania  
15:36:23 (xilinxd) OUT: "ap_opencl" xlmeng@oceania  
15:36:23 (xilinxd) IN: "SDAccel" xlmeng@oceania  
15:36:23 (xilinxd) IN: "ap_opencl" xlmeng@oceania  
15:36:23 (xilinxd) OUT: "ap_sdsoc" xlmeng@oceania  
15:36:23 (xilinxd) IN: "ap_sdsoc" xlmeng@oceania  
15:36:23 (xilinxd) OUT: "ap_sdsoc" xlmeng@oceania  
15:36:23 (xilinxd) IN: "ap_sdsoc" xlmeng@oceania  
15:36:59 (xilinxd) UNSUPPORTED: "vlm_check" (PORT_AT_HOST_PLUS   ) xlmeng@oceania  (License server system does not support this feature. (-18,327))

 

 Please help.

client2.jpg
license3.jpg
license4.jpg
license5.jpg
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
451 Views
Registered: ‎06-14-2010

Re: Floating license error: UNSUPPORTED: vlm_check (PORT_AT_HOST_PLUS )

Jump to solution

Hello @xlmeng,

 

The reason why you are seeing a licensing issue is because you have started your floating license with lmgrd v11.14, however you are still pointing to xilinxd vendor daemon v11.11, i.e. (this is found from your debug.log file that you've provided):

 

lmgrd version 11.14, xilinxd version 11.11

  Therefore, please restarted the server and make sure you are using v11.14 for both lmgrd and xilinxd. Vivado tools will then be able to detect your licenses.

 

When you open VLM (Vivado License Manger) and do a license search, a vlm_check command gets sent out to the server to check license status and to obtain all of the licensing info and the server features and once done, all of the found licenses would then get populated for you in VLM.
However, in relation to "UNSUPPORTED: vlm_check", this is an indication that you have started your floating license on some older version of Linux OS, which is not a supported by Xilinx tools. Since this OS is not a supported OS of Xilinx Tools, the server doesn’t know anything about this 'vlm_check' command and hence this message occurs in the debug.log file.

Anyhow, i believe if you start your server with lmgrd and xilinxd both v11.14, your Vivado tools should be satisfied and you should not see this issue then. Please gives this ago, and let us know how you'd get on.

If you have any questions for me, please let me know.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
2 Replies
Moderator
Moderator
452 Views
Registered: ‎06-14-2010

Re: Floating license error: UNSUPPORTED: vlm_check (PORT_AT_HOST_PLUS )

Jump to solution

Hello @xlmeng,

 

The reason why you are seeing a licensing issue is because you have started your floating license with lmgrd v11.14, however you are still pointing to xilinxd vendor daemon v11.11, i.e. (this is found from your debug.log file that you've provided):

 

lmgrd version 11.14, xilinxd version 11.11

  Therefore, please restarted the server and make sure you are using v11.14 for both lmgrd and xilinxd. Vivado tools will then be able to detect your licenses.

 

When you open VLM (Vivado License Manger) and do a license search, a vlm_check command gets sent out to the server to check license status and to obtain all of the licensing info and the server features and once done, all of the found licenses would then get populated for you in VLM.
However, in relation to "UNSUPPORTED: vlm_check", this is an indication that you have started your floating license on some older version of Linux OS, which is not a supported by Xilinx tools. Since this OS is not a supported OS of Xilinx Tools, the server doesn’t know anything about this 'vlm_check' command and hence this message occurs in the debug.log file.

Anyhow, i believe if you start your server with lmgrd and xilinxd both v11.14, your Vivado tools should be satisfied and you should not see this issue then. Please gives this ago, and let us know how you'd get on.

If you have any questions for me, please let me know.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Highlighted
Visitor xlmeng
Visitor
433 Views
Registered: ‎06-21-2018

Re: Floating license error: UNSUPPORTED: vlm_check (PORT_AT_HOST_PLUS )

Jump to solution

@anatoli,Thanks very much for your help.

I have fixed this problem.

I have set the enviorment of PATH which the xilinxd redirect to the old version.

Since the zip file(Floating Server Tools Linux (Flex v11.14.1.0) ) was unzip, and all files had no execute permission. 

I overpassed the xilinxd file, and forget to add execute permission to it, that is the reason of this problem.