cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
9,318 Views
Registered: ‎01-01-2016

Have a original vivado .lic file. Still license error occurs

Jump to solution

Hi,

 

I have a original vivado license file which i got the with the Artix 7 FPGA board. After installing the license, i can see that the Expiration date is set to "Permanent" in the license manager. But still i get this error while running the simulation or synthesis.

 

ERROR: [Simtcl 6-50] Simulation engine failed to start: A valid license was not found for simulation. Please run the Vivado License Manager for assistance in determining which features and devices are licensed for your system.

Thanks for the help in advance.

Capture.JPG
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
13,589 Views
Registered: ‎02-14-2014

Hello @sandy_1022,

 

From the env_new.txt file attached in your earlier post, it seems that there is hostID mismatch between your system's hostID and the one for which license is generated. The hostID of your system is ee3b549 and the one in license file is a683ff30. You need to re-host the license for your system by following below AR 

http://www.xilinx.com/support/answers/36136.html

 

Let us know if you face any problems after rehosting license.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

34 Replies
Highlighted
Moderator
Moderator
9,313 Views
Registered: ‎07-01-2015

Hi @sandy_1022,

 

Welcome to Xilinx Forums Community.

 

Please share the .lic file and output xinfo.txt of following command in Tcl console.

report_environment -file xinfo.txt

 

Which device you are targeting?

 

Thanks,
Arpan

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
9,307 Views
Registered: ‎01-01-2016

Hi,

Thanks a lot for the quick response. I'm very glad.

 

Please find the response i got from tcl console.

I have also attached the .lic file for your refenrence.

report_environment -file xinfo.txt
INFO: [Common 17-635] Now fetching report information. This may take some time.
INFO: [Common 17-633] Fetching system information...
INFO: [Common 17-632] Fetching software environment information...
INFO: [Common 17-629] Fetching Vivado preferences...
INFO: [Common 17-630] Fetching installation information...
INFO: [Common 17-628] Fetching DLL information...
INFO: [Common 17-631] Fetching license information...
INFO: [Common 17-634] Done fetching report information.

 

I'm sorry. I didn't get you about the device. I have created a project using ISE Xilinx  Design suite 14.7 and i am using the same file to run on Vivado 2015.4  for FPGA implementation. .

 

Thanks in advance for your help.

 

 

Tags (1)
0 Kudos
Highlighted
Explorer
Explorer
9,290 Views
Registered: ‎01-01-2016
do you have any solution for me please?
Tags (2)
0 Kudos
Highlighted
Moderator
Moderator
9,238 Views
Registered: ‎01-16-2013

@sandy_1022,

 

Share the xinfo.txt as well!

To generate xinfo.txt, Click Start -->Xilinx Design tool--> ISE design entry 14.x --> Accessories--> Xinfo System checker

Capture.PNG

 

You can also generate same from Vivado by running the below command in Vivado TCL console:

report_environment -file <path>/xinfo.txt

 

Your license can be using for XC7A200T only.

 

--Syed

 

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
9,212 Views
Registered: ‎01-01-2016

Hi @syedz

 

Thanks for your response. 

If i run the tcl console i get an error like this.

 

report_environment -file <path>/xinfo.txt
ERROR: [Common 17-37] Directory in which file xinfo.txt is to be written does not exist [<path>]

 

but this what i got from the other option you mentioned(start menu). But again i think this is for 14.7 ise design suite which is also installed in my system and not for vivado because i didnt find accessories under vivado directory. I have attachede both pics for your reference. 

 

Also you might be right about the device. It is mentioned in the FPGA kit that it is set to xc7a200T only. 

what should i do now?

 

thanks for your response

 

 

Capture2.JPG
Capture1.JPG
0 Kudos
Highlighted
Explorer
Explorer
9,209 Views
Registered: ‎01-01-2016

Hi @syedz,

 

After you mentioned, about the device

l also tried changing the decive to xc7a200t. But i still get the same license error which i got previously.

 

Do i need to specify a specific device or any device under Artix 7 family works? Because my board is a Artix 7 fpga c701 kit.

 

Thanks again,

Sandy

Capture3.JPG
0 Kudos
Highlighted
Moderator
Moderator
9,172 Views
Registered: ‎07-01-2015

Hi @sandy_1022,

 

<path>/xinfo.txt 

 

Here <path> means something like C:/Users/..

else just run

 

report_environment -file xinfo.txt

 

and attach xinfo,txt here.

 

Thanks,
Arpan

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
9,164 Views
Registered: ‎01-01-2016

Hi @arpansur

 

please find the result i got by running    report_environment -file xinfo.txt

 

Thanks again for helping me,

Sandy

 

8.JPG
0 Kudos
Highlighted
Moderator
Moderator
9,159 Views
Registered: ‎07-01-2015

Hi @sandy_1022,

 

The outputs will be written to xinfo.txt file. Please attach that file.

Please use the following Tcl command to get the location where the xinfo.txt file is saved.

pwd

 

Thanks,
Arpan

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
8,096 Views
Registered: ‎01-01-2016

@arpansur

 

I'm sorry i didn't get you the first time. 

Please find the text file attached.

 

Thanks,

Sandy

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,065 Views
Registered: ‎02-16-2014

hi @sandy_1022

 

From the xinfo file that you have attached there is no Vivado license installed on your machine.This is the reason for what you are seeing during simulation.

Please install the license properly by following below steps.

 

Open Vivado License Manager -> Load License -> Copy License and point to the directory where this device locked license is present.

 

Capture.JPG

 

Now restart Vivado and run simulation with part XC7A200T-2FBG676C.

Highlighted
Explorer
Explorer
8,045 Views
Registered: ‎01-01-2016

Hi @pulim

 

I'm not getting the part   XC7A200T-2FBG676C  that you have mentioned in your post. 

Please find the pic attached. 

Also i had got the same message when i loaded the License file previously too. It said license attached successfully.

Can you think of any other problem? I also read this other post where it was a floating license. Am i having the same problem?

 

Thanks,

Sandy

9.JPG
8.JPG
0 Kudos
Highlighted
Moderator
Moderator
8,033 Views
Registered: ‎07-01-2015

Hi @sandy_1022,

 

Just as a debugging step:

Can you please try running a small design with XC7Z010 and let us know the outcomes.

 

Thanks,
Arpan

 

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
8,030 Views
Registered: ‎01-01-2016

Hi @arpansur

 

I'm still facing the same error as before. 

0 Kudos
Highlighted
Explorer
Explorer
8,029 Views
Registered: ‎01-01-2016
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,003 Views
Registered: ‎02-14-2014

Hello @sandy_1022,

 

From xinfo, It seems the license which you have installed is different than the one which you have attached in this thread. (Start date and version limit is different), can you point the directory name of attached Xilinx.lic to XILINXD_LICENSE_FILE variable after clicking "Manage License Search Paths" in Vivado License Manager? Then click on 'Set' and check with any webpack device. 

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Highlighted
Moderator
Moderator
7,999 Views
Registered: ‎06-24-2015
Also, after implementing Ashish's suggestion, please run the following command in tcl console and share the generated env_new.txt file:
report_environment -file env_new.txt

Also, run an example design to see if it is working.

Also, can you tell us if you installed the webPACK edition or the System edition of Vivado?
Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
Highlighted
Moderator
Moderator
7,993 Views
Registered: ‎07-01-2015

Hi @sandy_1022,

 

You can search device  XC7A200T-2FBG676C using the following format

XC7A200TFBG676-2

 

Thanks,
Arpan

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
2.JPG
Highlighted
Explorer
Explorer
7,987 Views
Registered: ‎04-28-2015

Hi @sandy_1022

 

Please check arpan's suggestion on how to select that device.

Alternatively, you can also select it using the drop down menu. (PFA)

 

Thanks,

Tushar

1.JPG
Highlighted
Moderator
Moderator
8,105 Views
Registered: ‎01-16-2013

Hello @sandy_1022,

 

Any update on this Licensing issue. Hope the above shared suggestions were helpful.

Let us know if you are still facing any Error.

 

--Syed

 

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
8,093 Views
Registered: ‎01-01-2016

Hi @ashishd

 

I'm sure its the same License file. But i will attach it again for your reference.

Also set XILINXD_LICENSE_FILE to file path as shown in the snip.

 

Thanks for you continuous help,

Sandy

11.JPG
10.JPG
0 Kudos
Highlighted
Explorer
Explorer
8,092 Views
Registered: ‎01-01-2016

Hi @nupurs

Please find the text file i got by running the   report_environment -file env_new.txt  command in tcl console.

I ran a simple AND gate code which works perfectly fine in ISE 14.7(checked)(Code attached)

I installed a SYSTEM EDITION

 

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////

module and_gate(
input [4:0] a,
input [4:0] b,
output [4:0] c
);
assign c=a&b;

endmodule

 

 

module and_g_tb;

// Inputs
reg [4:0] a;
reg [4:0] b;

// Outputs
wire [4:0] c;

// Instantiate the Unit Under Test (UUT)
and_gate uut (
.a(a),
.b(b),
.c(c)
);

initial begin
// Initialize Inputs
a = 0;
b = 0;

// Wait 100 ns for global reset to finish
#100;
a=00010;
b=00110;
#50;
a=0111;
b=1000;

// Add stimulus here

end

endmodule

//////////////////////////////////////////////////////////////////////////////////////////////////////////////////

 

Hi @arpansur

Hi @tusharvi

Thank you , i found the device. 

Please find attached for confirmation.

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////

Hi @syedz

 

Yes. After having done all the above changes, i'm still facing the License errors. 

I have attached a copy of it below.

 

Thanks all for the continuous help,

Hope we can fix it out .

Sandy

13.JPG
14.JPG
0 Kudos
Highlighted
Explorer
Explorer
8,089 Views
Registered: ‎01-01-2016

Hi @syedz

@tusharvi

@arpansur

@nupurs

@ashishd

 

I will also attach the xinfo.text file for your reference.

 

 

Thanks,

Sandy

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
13,590 Views
Registered: ‎02-14-2014

Hello @sandy_1022,

 

From the env_new.txt file attached in your earlier post, it seems that there is hostID mismatch between your system's hostID and the one for which license is generated. The hostID of your system is ee3b549 and the one in license file is a683ff30. You need to re-host the license for your system by following below AR 

http://www.xilinx.com/support/answers/36136.html

 

Let us know if you face any problems after rehosting license.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

Highlighted
Explorer
Explorer
8,059 Views
Registered: ‎01-01-2016

Hi @ashishd,

 

I think i know why that happened. This License file was downloaded by my friend on his PC. Can we not share the same License file in multiple PC's? Both of us need to use vivado 2015.4 for our projects using the same ARTIX 7 fpga c701 board.

 

 

Thanks,

Sandy

0 Kudos
Highlighted
Explorer
Explorer
8,055 Views
Registered: ‎04-28-2015

.Hi Sandy,

In case of activation based licenses (Vivado), if the license is nodelocked, it can only be used for the machine on which the license creation request was generated. An exception to this is Webpack license which can be used on multiple machines as it won't have a host id attached to it.

Can you please let us know the details of the license you are trying to use?

Edit: I just saw your initial note and noted that you are using the license that you obtained with Artix 7 FPGA board

If you are using this license, it can only be used on a single machine.

Thanks,
Tushar.

Highlighted
Xilinx Employee
Xilinx Employee
8,045 Views
Registered: ‎02-14-2014

Hello @sandy_1022,

 

Since this is device locked license (non-webpack), it can't be shared. You need to rehost it by following AR mentioned in my earlier post.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Highlighted
Moderator
Moderator
8,043 Views
Registered: ‎07-01-2015

Hi @sandy_1022,

 

You can download webpack license for your system using VLM. XC7A200T is supported in Vivado 2015.4 webpack devices.

Please go through page 15 of following link for the same information.
http://www.xilinx.com/support/documentation/sw_manuals/xilinx2015_4/ug973-vivado-release-notes-install-license.pdf

 

To download webpack license for Vivado please go through following steps.(Go through the attachments)

 

After clicking on "Connect Now" you will be directed to Xilinx Licensing site.

Login with your credentials and get the license.

 

Please let us know if you are facing any problem in downloading webpack license.

 

Thanks,
Arpan

 

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
1.JPG
2.JPG
Highlighted
Explorer
Explorer
8,032 Views
Registered: ‎01-01-2016

@arpansur

 

Should i be using certificate based license or activation based license for obtaining web pack license?

and which among those options?

I just want to be extra careful this time with the license file. 

 

 

Thanks,

Sandy

7.JPG
0 Kudos