We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Observer wkoszek
Registered: ‎08-01-2008

ISE 11.1 fails with "write permissions..." under UNIX -- complete report


My report is about this bug:


Unfortunately, solutions aren't universal and don't apply to UNIX. I don't
use FAT32 in any way. This report was motivated by the fact that I want to
write a tutorial on getting Xilinx ISE running on FreeBSD 9 CURRENT.  
I see that some users experienced the same problem and I decided to give
some more insight on this issue. Xilinx team is welcome to comment/help.

My configuration is based on UFS2 filesystem:

# newfs -N /dev/ad2s1a
/dev/ad2s1a: 30720.0MB (62914560 sectors) block size 16384, fragment size 2048
using 168 cylinder groups of 183.77MB, 11761 blks, 23552 inodes.
super-block backups (for fsck -b #) at:
160, 376512, 752864, 1129216, 1505568, 1881920, 2258272, 2634624,

And user-space libraries come from Fedora 10 emulation ports available in FreeBSD
ports collection.

Good news: picking up only "DSP tools" alone works. And this is the end of 
good news. Bad news is what the rest of this mail is all about.

My steps are based on this file:

# md5 Xilinx_11.1_WebPack_SFD.tar
MD5 (Xilinx_11.1_WebPack_SFD.tar) = cdbad7bb6e2fc0ca24fe5a1e01d847d6
# sha1 Xilinx_11.1_WebPack_SFD.tar
SHA1 (Xilinx_11.1_WebPack_SFD.tar) = ecad3b324e8761a4e9373f2e8052493b01fff9b4
I untar it with:

tar -xf Xilinx_11.1_WebPack_SFD.tar
From the main directory, I run:

I pick default settings. Once started, ISE installation proceeds till 39%.
Just after that, I get the same problem which GNU/Linux and Microsoft
Windows people reported:

You may not have write permissions for the /opt/Xilinx/11.1/ISE directory or its subdirectory
 "Error in zipfile" Please correct this and then select Retry

I set read/write/execute (UNIXish 0777 evil setting) for all files within
/opt and /X (installer's directory), but it didn't help either.

Anyway, when reaching 39%, installer reports that it is unpacking this file:

drop0292_iSE_L33_10.zip.xz (50363 KB)
On my file system, it is present as:

# ls -la drop0292_iSE_L33_10.zip.xz
-rwxrwxrwx 1 20230 902 46284009 Apr 11 2009 drop0292_iSE_L33_10.zip.xz
On the terminal from which I've started `xsetup` I see:

  /opt/Xilinx/11.1/ISE/virtex4/data/virtex4.dst bad CRC ef398c14  (should be fdfe6f00)
  (may instead be incorrect password)
We're talking about this file:

# ls -la /opt/Xilinx/11.1/ISE/virtex4/data/virtex4.dst
-rw-r--r-- 1 root wheel 5616469 Mar 27 2009 /opt/Xilinx/11.1/ISE/virtex4/data/virtex4.dst
On my laptop with ISE 11.1 however, it's much bigger [1]:

wkoszek@laptop:/compat/linux$ ls -la opt/Xilinx/11.1/ISE/virtex4/data/virtex4.dst
-rw-r--r-- 1 root wheel 16536971 27 mar 2009 opt/Xilinx/11.1/ISE/virtex4/data/virtex4.dst
I don't know what can cause your installer to unpack files badly, but this
ZIP file seems to contain correct virtex4.dst file:

# zipinfo drop0292_iSE_L33_10.zip.xz
Archive: drop0292_iSE_L33_10.zip.xz
Zip file size: 46284009 bytes, number of entries: 13
drwxr-xr-x 2.3 unx 0 BX stor 09-Mar-27 17:09 virtex4/
drwxr-xr-x 2.3 unx 0 BX stor 09-Mar-27 17:09 virtex4/data/
-rw-r--r-- 2.3 unx 16536971 BX defX 09-Mar-27 17:09 virtex4/data/virtex4.dst
drwxr-xr-x 2.3 unx 0 BX stor 09-Mar-27 17:09 virtex5/
drwxr-xr-x 2.3 unx 0 BX stor 09-Mar-27 17:09 virtex5/data/
-rw-r--r-- 2.3 unx 11754077 BX defX 09-Mar-27 17:09 virtex5/data/virtex5.dst
-rw-r--r-- 2.3 unx 9621754 BX defX 09-Mar-27 17:09 virtex5/data/virtex5.small.dst
-rw-r--r-- 2.3 unx 4902658 BX defX 09-Mar-27 17:09 virtex5/data/5vlx50t.grf
-rw-r--r-- 2.3 unx 4500048 BX defX 09-Mar-27 17:09 virtex5/data/5vlx50.grf
-rw-r--r-- 2.3 unx 4256912 BX defX 09-Mar-27 17:09 virtex5/data/5vfx30t.grf
drwxr-xr-x 2.3 unx 0 BX stor 09-Mar-27 17:09 .xinstall/
drwxr-xr-x 2.3 unx 0 BX stor 09-Mar-27 17:09 .xinstall/mnf/
-rw-rw-rw- 2.3 unx 155 TX defX 09-Mar-27 17:09 .xinstall/mnf/drop0292_iSE_L33_10.mnf
13 files, 51572575 bytes uncompressed, 46281689 bytes compressed: 10.3%
And its size matches exactly with my laptop's file size. As I said, DSP
tools installation succeeded, but PlanAhead installation fails as well.
Symptoms are similar -- installation proceeds till 11%, hangs on:

drop0009_Pla_11_1_1238117799.zip.xz (50897 KB)
On my disk it's visible as:

% ls drop0009_Pla_11_1_1238117799.zip.xz
-rwxrwxrwx 1 20230 902 17250749 Apr 11 2009 drop0009_Pla_11_1_1238117799.zip.xz
Information about this ZIP file:

%zipinfo drop0009_Pla_11_1_1238117799.zip.xz
Archive: drop0009_Pla_11_1_1238117799.zip.xz
Zip file size: 17250749 bytes, number of entries: 65
-rw-r--r-- 2.3 unx 10669 TX defN 09-Mar-05 19:20 tps/lnx24/j2re1.6.0_11/lib/psfontj2d.properties
-rw-r--r-- 2.3 unx 1140700 BX defN 09-Mar-05 19:20 tps/lnx24/j2re1.6.0_11/lib/resources.jar
-rw-r--r-- 2.3 unx 50853661 BX defN 09-Mar-05 19:20 tps/lnx24/j2re1.6.0_11/lib/rt.jar
-rw-r--r-- 2.3 unx 2469 BX defN 09-Mar-05 19:20 tps/lnx24/j2re1.6.0_11/lib/security/US_export_policy.jar
-rw-r--r-- 2.3 unx 64736 BX defN 09-Mar-05 19:20 tps/lnx24/j2re1.6.0_11/lib/security/cacerts
When bug happens, following message appears on the terminal:

error: invalid compressed data to inflate /opt/Xilinx/11.1/PlanAhead/tps/lnx24/j2re1.6.0_11/lib/rt.jar
File itself is here:

-rw-r--r-- 1 root wheel 46202880 Mar 5 2009 /opt/Xilinx/11.1/PlanAhead/tps/lnx24/j2re1.6.0_11/lib/rt.jar
Some details about it:

%ls -la /opt/Xilinx/11.1/PlanAhead/tps/lnx24/j2re1.6.0_11/lib/rt.jar
-rw-r--r-- 1 root wheel 46202880 Mar 5 2009 /opt/Xilinx/11.1/PlanAhead/tps/lnx24/j2re1.6.0_11/lib/rt.jar
%cd /tmp/
%cd m
%mkdir TEST
%cd TEST
%unzip /opt/Xilinx/11.1/PlanAhead/tps/lnx24/j2re1.6.0_11/lib/rt.jar > rt_jar_unzipped.txt
unzip: Truncated ZIP file header
Output file from "unpack procedure" is here:

Will this be enough to say something more about root of the problem? And
I really mean *root*, since I can't easily apply known Microsoft Windows
solutions here...

Hints on how can I unpack those *iSE*.zip.xz files are welcome. I tried to
do cat *iSE*.zip.xz > ISE.zip, but it doesn't seem to give me sensible ZIP

[1] Please don't ask me, how is it possible that using the very same TAR
  file let me to install ISE on my laptop without a problem in the past...

[2] Editing this post redefined PITA, since forums still don't seem to work 
under Opera (10.10 for FreeBSD this time). You don't want to know how
inserting line break looks like.


Wojciech A. Koszek
Wojciech A. Koszek
0 Kudos
3 Replies
Observer wkoszek
Registered: ‎08-01-2008

Re: ISE 11.1 fails with "write permissions..." under UNIX -- complete report



My previous report was referring to the old ISE 11.1 package version. I have updated

a package, and right now I'm able to complete WebPack 11.1 installation  on FreeBSD

without a problem. Problems with inappropriate packages and files went away. Expect

separate thread with a tutorial here really soon.


For completeness, I present validated checksums:


# md5 /home/wkoszek/Xilinx_11.1_WebPack_SFD.tar
MD5 (/home/wkoszek/Xilinx_11.1_WebPack_SFD.tar) = 42ce70bd3f78e68295175db2441c8b3a
# sha1 /home/wkoszek/Xilinx_11.1_WebPack_SFD.tar
SHA1 (/home/wkoszek/Xilinx_11.1_WebPack_SFD.tar) = 2b57b4fb00914e50d1b0a4d0a49e511ca56e85fb

Wojciech A. Koszek
0 Kudos
Visitor cederom
Registered: ‎01-25-2010

Re: ISE 11.1 fails with "write permissions..." under UNIX -- complete report

Hello Wojciech!


I was fighting to run ISE12 on my FreeBSD box. There are much more dependencies in 12 than in 11, luckily the all necessary dynamic libraries are provided with installation, so we only need to fedd them into ldconfig :-)




Best regards,


0 Kudos
Visitor cederom
Registered: ‎01-25-2010

Re: ISE 11.1 fails with "write permissions..." under UNIX -- complete report

Unfortunately new Xilinx ISE (13.1) does not provide all dynamic libraries required to work, unfortunately :-(


However there is a solution to run ISE on FreeBSD, please take a look at:


or directly



0 Kudos