cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
682 Views
Registered: ‎03-18-2019

ISE Foundation 4.2i

Hi ,

      Im working on very old design Spartan XL(XCS30XL)  as part of obsolescence .I have to recompile the design once with spartan XL before i upgrade to newer FPGA. I was able to download and install ISE Foundation 4.2i which supports this device . The code is written in verilog , ISE Foundation 4.2i only supports EDIF flow and when i try to open the old project it throws a error saying "FPGA EXpress Verilog Flow" is not supported. I checked this, earlier Xilinx used synthesis tools from Synopsys (https://www.xilinx.com/support/answers/13964.html) which is no longer provided. XST which is xilinx synthesis tool doesnt support  Spartan XL devices. Can anyone suggest workaround for this?

Regards,

VK

 

 

0 Kudos
8 Replies
Highlighted
Moderator
Moderator
633 Views
Registered: ‎06-14-2010

Hello @vk8583 ,

You see, back then, with Alliance/Foundation Design Tools installation you were required to have FPGA Express, as the synthesis tool that was shipped with the earlier tools was FPGA Express and this tool was created by Synopsys.  Due to the legal agreements (please refer to the answer record 14930: https://www.xilinx.com/support/answers/14930.html) we can no longer generate any licenses.  Before this was in place lifetime licenses were sent to customers that did not expire. Therefore, even if we have the Foundation 4.2i installation, you also need FPGA Express 3.4 and the corresponding license for it, which you won’t be able to get due to the legal agreements back in May, 2002.

If you check this Answer Record: https://www.xilinx.com/support/answers/15938.html , here you can find that ISE 4.2 (and not Alliance/Foundation software but an ISE related):

image.png

Therefore, you can download and use ISE version 4.2 or earlier (instead of Foundation versions) and use this instead if you need to targer this particular device with ISE legacy software.

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
605 Views
Registered: ‎03-18-2019

Hi anatoli,

                 Thanks for your reply, I Installed  4.1i webpack from archive but spartan-XL is not listed as supported devices for webpack variant. Then i tried 4.2i from archive there is no webpack variant available on full product installation the link is given below .

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/design-tools/archive.html

Then i selected registration ID from the below link for ISE Webpack and it throws error saying not a valid ID. Then i tried with reg id for ISE BaseX 

https://www.xilinx.com/member/10x_and_prior_regids.html#7x

variant , in this device is listed but again no VHDL/Verilog support on EDIF. Can u suggest the path from where i can install proper version/variant which supports spartan XL series along with VHDL/Verilog.

Regards,

 

0 Kudos
Highlighted
Moderator
Moderator
596 Views
Registered: ‎06-14-2010

Hello @vk8583 ,

Tried downloading and using ISE 3.1 Standard version. As this is not availble on Xilinx Downloads page, I have sent this to you via the tool called EZMove, so that you can give this a try. The Reg ID for ISE 3.1 Standard edition can be found here:

https://www.xilinx.com/member/10x_and_prior_regids.html#7x

I've just gave this a try and the required device is there, as shown in my screenshot below. This should work fine for you:

ise3.1.PNG

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
591 Views
Registered: ‎03-18-2019

Hi Anatoli,

               Thanks for the download...i will install and check it..I wanted to check one more thing with you ...whether this installation will work on Windows XP station?

Regards,

VK

0 Kudos
Highlighted
Moderator
Moderator
587 Views
Registered: ‎06-14-2010

Hello @vk8583 ,

Yes, you should have no issues installing this on Windows XP machine. I've tried this on Windows XP Virtual Machine and i had no issues, so this should also work fine for you too.

Please give this a go and let me know how you'd get on. Hope all works fine for you.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
566 Views
Registered: ‎03-18-2019

Hi anatoli,

                Thanks for the software , i was able to install it succesfully . But again there is problem with FPGA Express i'm getting this error when i try to synthesize 

unable to obtain license for FPGA Express

Done :failed with exit code :65535

Another problem is how to avoid inferring global buffer in FPGA express because its throwing "Error:OldMap:56", i have used IO as clock in code but assigned to normal IOB (required alternate for CLOCK_DEDICATED_ROUTE = FALSE)

Regards,

VK

0 Kudos
Highlighted
Moderator
Moderator
551 Views
Registered: ‎06-14-2010

Hello @vk8583 ,

If this is in relation to FPGA Express, then you'd need a valid license for this. This tool was created by Synopsys. As already indicated, due to the legal agreements (please refer to the answer record 14930: https://www.xilinx.com/support/answers/14930.html) we can no longer generate any licenses.  Before this was in place lifetime licenses were sent to customers that did not expire. Therefore, you'd also need FPGA Express 3.4 and the corresponding license for it, which you won’t be able to get due to the legal agreements back in May, 2002.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
543 Views
Registered: ‎03-18-2019

Hi anatoli,

              Without FPGA Express how else can i create project/synthesize/generate bit file for Sparatan XL series FPGA? Any workaround. 

             Regarding setting "clock dedicated route false" in 3.1i , how can it be done.

Regards,

VK

0 Kudos