UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor michaelgr
Visitor
1,077 Views
Registered: ‎05-08-2018

Licence error synthesis IP cores

Jump to solution

Hello

 

I try to synthesis a design from a costumer which should work. But I get license errors like:(for many parts like the Clk wizard, or fifo_generator or axi_crossbar)

 

[Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xc7vx485t-ffg1157'. Please run the Vivado License Manager for assistance in determining
which features and devices are licensed for your system.
Resolution: Check the status of your licenses in the Vivado License Manager. For debug help search Xilinx Support for "Licensing FAQ". 

My Report for the ip prints at license "Included" for those parts. So how can I figure out what license do i have and what components can i use?

 

best regards,

Michael

 

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,247 Views
Registered: ‎03-16-2017

Re: Licence error synthesis IP cores

Jump to solution

Hi @michaelgr,

 

Based on your license file vivado_system_edition has a version limit of 2016.10 which means 10th month of 2016. It cannot be used with the latest Vivado tools which are released after this date.

 

Based on this AR https://www.xilinx.com/support/answers/33770.html you need minimum version limit of 2017.10 for Vivado 2017.3.

 

Resolution: Either you can purchase a new license for latest Vivado 2018.1 system edition or you can use Vivado 2016.3 with this older license file.

 

Regards,

hemangd

 

-- Close this thready by marking accepted solution so community remains healthy.

 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.

View solution in original post

6 Replies
1,056 Views
Registered: ‎06-21-2017

Re: Licence error synthesis IP cores

Jump to solution

Do you have a purchased license or a Web Pack license?  I don't think Web Pack supports a large Virtex 7.

0 Kudos
Visitor michaelgr
Visitor
1,049 Views
Registered: ‎05-08-2018

Re: Licence error synthesis IP cores

Jump to solution

I am using the license from a company server. Licenses at xilinx are very muddy maybe I should better find out who the technical support is.

 

is there no easy way to detect which devices are supported.

 

br,

Michael

0 Kudos
Scholar jmcclusk
Scholar
1,031 Views
Registered: ‎02-24-2014

Re: Licence error synthesis IP cores

Jump to solution

Open Vivado, and go to "Help" -> "Manage License"  This brings up the Vivado License Manager, and it will show you all the licenses (both floating and node-locked) that it can detect.    You may not be pointing properly to your company server.  The environmental variables  XILINXD_LICENSE_FILE and LM_LICENSE_FILE  (either one) need to be set properly.

Don't forget to close a thread when possible by accepting a post as a solution.
0 Kudos
Moderator
Moderator
1,015 Views
Registered: ‎03-16-2017

Re: Licence error synthesis IP cores

Jump to solution

Hi @michaelgr,

 

To find out the root cause of this issue , i will require below mentioned docs.

 

1. Provide license files which you are using for your project design.

2. Run "report_environment -file <filepath>/env.txt" and share the env.txt to evaluate it. 

3. Also provide the snapshot of the errors and in which stage you are facing those errors.

 

Regards,

hemangd

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Visitor michaelgr
Visitor
972 Views
Registered: ‎05-08-2018

Re: Licence error synthesis IP cores

Jump to solution

Can i contact you via email?

 

br,

michael

0 Kudos
Moderator
Moderator
1,248 Views
Registered: ‎03-16-2017

Re: Licence error synthesis IP cores

Jump to solution

Hi @michaelgr,

 

Based on your license file vivado_system_edition has a version limit of 2016.10 which means 10th month of 2016. It cannot be used with the latest Vivado tools which are released after this date.

 

Based on this AR https://www.xilinx.com/support/answers/33770.html you need minimum version limit of 2017.10 for Vivado 2017.3.

 

Resolution: Either you can purchase a new license for latest Vivado 2018.1 system edition or you can use Vivado 2016.3 with this older license file.

 

Regards,

hemangd

 

-- Close this thready by marking accepted solution so community remains healthy.

 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.

View solution in original post